Timing problems from MIDI generated by... Reaktor 6?

Hi there

I wanted to experiment with sounds driven by a sequencer that switches randomly between two different sequences on various beats.

So I built a patch in Reaktor 6, which generates MIDI pitch/gate signal that I can route from Reaktor to an external destination, or just use to control a synthesizer voice inside of Reaktor itself.

When I use Reaktor as a VSTi in a Cubase Instrument track, and I add a Reaktor synthesizer inside the same Reaktor file (sequencer and synth as one Reaktor instrument, purely within one Cubase track), it synchronises to Cubase fine and Reaktor generates audio right on time. Maybe it even sometimes sounds funky.

BUT if I use the Cubase track inspector to route Reaktor’s MIDI output to another Instrument track (e.g. Retrolog), using the Reaktor Instrument track purely as a MIDI source, the timing’s VERY sloppy. More than audibly sloppy, and not J Dilla drunk-sounding - it’s kind of floor-emptying, music-breaking sloppy.

Has anyone experienced this kind of problem, or know why it’s happening, or if there’s a workaround?


Just to say, I’ve tested the same Reaktor 6 patch in Ableton Live 10. In Live, timing is tight and accurate when I use the Reaktor 6 MIDI to trigger a 2nd VSTi (U-He Diva in this case) on a separate Ableton MIDI track.

So the problem is not simply due to Reaktor - it’s something to do with the way MIDI is handled in Cubase 10.5.


it might have to do with ASIO-guard?
Do you have both Tracks (in your example the Reaktor track and the Retrologue track) Midi Input enabled? If not, you might try so.


Thanks, I’ll check those out when I’m at my PC next!