Too many characters in my file names - can't copy/paste

Hi - Hoping a computer guru can help me back out of a problem caused by my naming music files with too many characters.

I use Paragon backup routines, no compression, and they all go swimmingly. However, I don’t have a “test” computer to see if I can recover that information, so as of now, I don’t have the confidence that my data is truly backed up.

I have tried to just copy from my DAW computer to the terabyte external drive, but Windows is unhappy because some of my filenames are “too long” to copy.

I was wondering - does anyone know of some method to make Windows happy enough to do the copy? There are many many files that have been labelled too long, so it’s not just a matter of renaming a few.

Thanks much -

Haven’t tried these options out yet, but for someone else who might have similar problems, I got this from another site:

1. DOS commands
XCOPY c:/mydocs/afile.txt c:/temp

You can copy multiple files by using the wildcard *.

XCOPY c:/mydocs/*.txt c:/temp

  1. Commercial product
    http://longpathtool.com/

Alexis …I find that the problem may not be the filename as such, but in the hierarchy of the folder structure the file is in when you try & copy the file. I ficnd it to be best to move your files to one top level folder & move it to a top level folder on the receiving drive.

Hey Discoworx -

Thanks for the reply very much.

I think I have an idea in theory what you are saying, but would you please explain that in a little bit more detail? What I am doing now (which isn’t working) is "copy"ing my E:\ drive icon (where my projects and audio reside), and "paste"ing it in an empty folder on an external hard disk.

Thanks again, and in advance for any clarification!

Are you using the the Windows Explorer (and the mouse or keyboard) to do this?

Exactly how many characters are you talking about Alexis ?

You could try this program which I’ve used for yrs, first on the Amiga and now Windows :

http://www.gpsoft.com.au/index.html

You can d/l a 60 day trial version, which is not crippled in any way.

This topic may answer your question :

http://resource.dopus.com/viewtopic.php?f=3&t=16241

Thank you for that, Paul, I will look into that also. The comments on the forum seem exactly what is happening to me (including Windows not actually pointing to a specific file that is causing the problem).

If you do get the 60 day trial version and then decide you want to buy it ( can’t imagine why anyone would not want to buy it after using it ) let me know and i can give you a link to a couple of websites that give a 10% discount, if you want to save a few sheckles.

Thanks, Paul!