Too many hyphens in lyrics

I’m entering lyrics for the first time. I watched the “How To Work With Lyrics” video at https://www.youtube.com/watch?v=IfhDVl-vRRo, but unless I’m missing something, Dorico is behaving differently than what’s described in the video.

Please see the attached screenshot:
Screen Shot 3.png
No matter what I do, Dorico inserts two hyphens between these syllables, instead of one. I’ve tried various combinations of hypen/space, but cannot for the life of me figure out how to display only one hyphen here. How do I do that?

To clarify:

• From the A♭, if I type “hea-” I’m advanced to the B♭. From there, if I type another hyphen, I’m advanced to the C. Then I type “led,” [.]

That produces two hyphens.


• From the A♭, if I type “hea-” I’m advanced to the B♭. From there, if I type a space, I’m advanced to the C. Then I type “led,” [.]

That also produces two hyphens.


• From the A♭, if I type “hea” (with no hyphen), I’m advanced to the B♭. From there, if I type a space, I’m advanced to the C. Then I type “led,” [.]

That produces NO hyphen.


How do I produce a single hyphen?!

I don’t think there’s anything wrong in your picture. However, if you want to change the way Dorico displays the hyphens, you can check the settings in Engrave options (cmd/ctrl-Shift-E), Lyrics category, scroll down to Hyphens :wink:

Thanks for the reply.

  1. In my screenshot, the display of two hyphens is incorrect. There should be one hyphen. :slight_smile:

  2. When I hit ⌘-shift-E, I get the “error beep,” and nothing changes on the screen.

You can access the engraving options in Engrave mode, Engrave menu — it should then display the keyboard shortcut. I guess you must have been messing with the shortcut editor :wink:

I am a professional singer, and I often see more than one hyphen if the length between two syllables is big, because of many notes in between…

OK. I found the section you mentioned, MarcLarcher. For some odd reason, the keyboard shortcut doesn’t work unless you first switch to the Engrave tab.

(Steinberg, keyboard shortcuts should work anywhere in the application, irrespective of the currently selected tab. We shouldn’t have to select a specific tab for a certain shortcut to work. In this case, if the user is not presently on the Engrave tab, invoking the shortcut ⌘-shift-E should automatically switch to the Engrave tab and show the Engraving Options.) :slight_smile:

MarcLarcher, I’ll look at the Engraving Options to see if they help. Thanks again.

But ultimately, Steinberg, it shouldn’t be so difficult to enter a single hyphen on a single syllable. :slight_smile:

Actually, the keyboard shortcuts to the different options (Notation options, Engraving options, Layout options) do work from any tab in the app, since day 1. I find it very strange that it does not on your computer!

It’s standard practice in published music to show more than one hyphen when the distance between two syllables is big enough, and Dorico follows those established practices by default. As Marc has kindly explained, though, the program makes it very easy to change these settings if you don’t like them, and you should indeed find that the shortcuts for the various options dialogs, including Engraving Options, work from any mode. Not all keyboard shortcuts work from every mode, however, as one of the benefits of having the five different modes is that the same shortcut can pull double duty and perform a different operation based on context. An application like Dorico depends on heavy use of the keyboard for efficient use, so limiting all shortcuts to a single mode would place too great a restriction on the combinations that can be used.