TouchOSC on Android and Cubase 8.5 Pro in OSX

Hi all,

are there any other people successfully using TouchOSC on Android to send MIDI commands to Cubase Pro 8.5 on OSX?

I got everything setup. TouchOSC data is routed to its native TouchOSC Bridge program (all running the latest software version) and Cubase receives the MIDI messages.

However, whatever I do, I can’t get Cubase to record that incoming MIDI data. Grrrrrrrrrrrrr! I spend hours yesterday finding a solution.

Some have suggested switching to record the changes in Automation. However, that does not help me much as it is quite uncomfortable to work with. I checked and it indeed seems to work.

Anybody found a workaround or solution to the problem? How can I make Cubase record that incoming MIDI?

Using a regular MIDI controller works as expected.

When I inspect the recorded MIDI part, I can see that Cubase apparently records the incoming value changes but somehow forgets about the timing data of those signals. Super strange.

I tried to come up with a genius way to make Cubase work the incoming MIDI data (e.g. via a Transformer) to get it somehow magically fixed but I did not succeed.

Any ideas?


I’m successfully using TouchOSC on iPad, connected to Mac OS X.

Make sure, you are really sending MIDI data, not OSC data from your template in the TouchOSC app, please.

I have tried everything and cannot get this thing to work.


Could you describe your connection, Setup and what did you try, please?

I installed the Midi connector for pc (Touch OSC Bridge). I went to Devices and connected the TouchOSC in both ports… Generic remote, midi in and out.

On the phone I turn the app on and input the ip (it never finds host) I use simple layout and try to move faders etc, nothing.

Thanks for the quick reply


Make sure, the simple layout send MIDI data, not OSC.



Open the template in the TouchOSCEditor or monitor, what data is on the Input of TouchOSC (some MIDI Monitor application, like MIDI Monitor on Mac or MIDI-OX on Win).

Ive never opened the editor… I just installed and tried using… Ill get the editor.

Dled and checking out… thank you martin

I open the editor while everything else is up and its blank. I have no clue. I was more hoping for something to control a few faders… no ic on android… sucks too, i bought one for apple, but i hate that phone now.

After messing with it for a bit I still cant get any use… I see red and green signals in touchosc, but nothing seems to be controlled.

These signals means, something is send. But it seems, OSC data is sending. Did you try to make own 1 fader with MIDI in the Editor? Did you try all templates?

I have tried a few of the templates, but not making a fader. Ill try that today


Try this template, please.

Thank you, dling now. I was able to get editor up after installing java… I can see the simple osc build does have the volume faders sending midi. I will try yours and report back.

You got me on the rigth track bud!!! thank you so much sir. My only issue now is my assignments are wrong… I need to figure out how to make the volume faders control volume…


Use Generic Remote Device in Cubase, please (search the forum, it was already described many times).

well, it does not work as it should that is for sure… its got serious hiccups, but oh well. thannk you

I have set up and ipad touch osc with touchosc bridge . Cubase recognizes note on and off and ccs but the ccs dont get recorded in the right place . The notes do but the ccs are at -1000 bars . Any ideas ?