Track 'Auto Fade Settings' doesn't work per track as expected? [slight protocol change suggestion]

I always thought right clicking on a track and going to the ‘Auto Fade Settings…’ was a per track dependent setting, yet enabling the ‘Auto Fade In’ , ‘Auto Fade Out’, ‘Auto Crossfade’ options seems to enable them globally…

Am I wrong on this?

When going a tracks ‘Auto Fade Settings…’ the window is titled reflecting the track name. Whereas, going to Project > ‘Auto Fade Settings…’, the window is titled to reflect the project name… So it seems to be intended that they are different.

edit
See post 13 for protocol suggestion:

edit
Also, in terms of Window design ‘Use Project Settings’ is so close to ‘Length’ that it makes it seem as if they conform to each other only.

It’s because you have Use Project Settings checked.

ohhh my bad, I thought that had to do with the ‘Length’ setting, ie, use ‘Project Length Setting’ since that’s how the window is arranged. sort of bad windows design

edit
@steve
Also, doesn’t really explain why it changes it for all audio tracks - shouldn’t it only be using the ‘Project Settings’ for that specific track? And not engaging it for all audio tracks?

That is what it does here on 10.5 and 11.

Are you sure? the above gif is 10.5 - you can see it enables it for both tracks, not the one track.

No, I don’t see that. But maybe I have misunderstood.

Rephrase it as an all text bug repro, I’ll have another look.

-Turn off global Project Auto-Fade settings
-Add two audio tracks, name one ‘A’ and the other ‘B’
-Check both audio tracks that ‘Auto Fade In’, ‘Auto Fade Out’ and ‘Auto Cross Fade’ are off for both tracks, but ‘Use Project Settings’ is on:
A: ‘Auto Fade In’=off ‘Auto Fade Out’=off and ‘Auto Cross Fade’=off | ‘Use Project Settings’=On
B: ‘Auto Fade In’=off ‘Auto Fade Out’=off and ‘Auto Cross Fade’=off | ‘Use Project Settings’=On
-Select Audio Track: A and turn ‘Auto Fade In’ on for the one audio A track only.
-Check the other Audio track B auto-fade settings, error should be that ‘Auto Fade In’ has also been turned on.

Now I’m more confused- this is not what is shown in your gif.

It works like this here in C10.5:

Okay I’m also confused,

the only difference I can see between our gifs, is that ‘Use Project Settings’ for me, was already on when I opened up this dialogue.

I’ll have to test it some more, maybe there is a conflict somewhere

for clarity…

to replicate my steps, turn off your Global Project Auto Fades

see


For some reason, changing the one audio track, changes the other 2 AND the project settings

edit

I think the problem is that there is no smart differential override in the code, and because I am making a change to the single track with ‘Use Project Settings’ on, when there are no Auto-Fade Project settings, it’s changing the project settings to what I’m setting in the single track, thus changing all the other tracks as well.

That’s how it works. If Use Global… is active, you edit the global settings. Turn it off and and the track has its own.

Yeah i just figure that out.

I guess this is part user-error, part weird design.

It would make more sense to have a automatic differential override, whereby if there is a change that is different from the project settings, it becomes unchecked.

And then in addition to that, have a ‘Set as Global Project Settings’ button, which would then rewrite the Project Auto-Fade settings, and thus recheck the ‘Use Project Settings’ box.