Track Inspector VST Routing - list of VSTs doesn't scroll

Hello all. I’m a new Dorico convert, but I’m having an issue and I’m not sure how to resolve it. I have created a list of various VSTs in the VST Rack tab (about 50 in total - large orchestra template). Using the Track Inspector - Routing tab I’ve been able to route 42 of them to each of their respective tracks. However, now I’ve hit an issue.

When I select the Dropdown of VSTs to assign it to my selected track (e.g. Violin 1), the list of VSTs in the routing dropdown will not scroll any farther beyond 42 - even though in the VST Rack tab I have 50 listed. Thus, hard to have a String section, if I can’t get to the strings VSTs and assign them to my tracks/players. :wink:

I have tried resizing the application window, flipping between Play, Write, etc., exiting and rebooting the app & file, and rebooting my Mac (Silicon Mac) to see if that solves the issue - it has not. Also, I am on a Duel monitor system using the second monitor for video playback (if that matters).

Would anyone have a solution to this issue? I’m under-the-gun on a cue deliverable, so any thoughts or assistance would be appreciated! Thanks!

Welcome to the forum, @composeravery. I’m sorry you’ve had this problem. It’s a bit unexpected, but you should find that you can click and drag the menu to scroll it. If you hold the mouse button down and then drag the list up, you should be able to see the items at the bottom of the list and then select them.

Thanks for your reply! I am able to drag up the list as you have suggested. However, I’m puzzled on how I would select the VST I need to assign, once I’m using the mouse to drag up the list? As soon as I let go of the mouse to select one of the “hidden” VSTs the list reverts back to its default state of hiding those extra VSTs below the viewable application window - see image example - and it continues to exhibit the same non-scrolling behavior as previously described.

screenShot_1

Any additional assistance is greatly appreciated! Thank you!

For every VST you add at the bottom of the VST rack, you should be able to select one more VST near the bottom of the dropdown list. By adding several temporary VSTs to the rack, you should be able to complete the routing using the dropdown list. Then you can delete the temporary VSTs from the rack.

Hi John, thanks for your response! I do already have several VSTs (a.k.a. my string section) within the VST Rack beyond where it’s getting cut off in the Track Inspector > Routing dropdown list. The last 8 VSTs in the Rack Tab are getting cut off in the Routing tab dropdown starting at VST #42 as the image above shows. I’m not able to scroll up to see those last 8 VSTs in the list. I am able to click & drag the mouse to reveal those last few VSTs in the list, but upon release (in order to select the VST for routing to track) the list reverts back to the cutoff like the image shows. :confused:

What I’m suggesting is for you to add 8 more temporary VSTs at the bottom of the VST rack so that when you scroll down the dropdown list, you will be able to select VSTs #42 through 49.

Another possible solution: Assuming you view Dorico on a widescreen monitor in landscape mode, you could close the Dorico project if it is open, switch the monitor into portrait mode, open the Dorico project and select VSTs from a much taller dropdown list. However, if you can’t pivot the monitor, you may find it difficult to move the mouse pointer where you want it to go!

Obviously this is all pretty unsatisfactory. I will have a conversation with my colleague Andrew, who has been leading the work on the revamped Play mode, and see if there’s anything we can do to ameliorate this in our next update.

Is there any chance one could use the up and down arrow keys to move to VSTs beyond the displayed list–at least until the Team solves the problem?

That’s a good idea, Derrek. By scrolling as close as possible to the bottom of the dropdown list with the mouse, moving the mouse pointer to the last VST in the displayed list, pressing down arrow and then pressing space, I can select the first VST beyond the displayed list.

On Windows, if I scroll as close as possible to the bottom of the dropdown list, only the last item cannot be selected with the mouse because it is hidden behind the taskbar at the bottom of the screen. However, if I execute the command View>Full Screen, the taskbar is hidden and I can select the last item in the dropdown list. The OP uses a Mac, and I don’t know if switching to full screen view would help him too.

Update: After more troubleshooting throughout the weekend and attempting one last idea, I’ve discovered that using Dorico 4 with a dual monitor setup is causing my “hidden VSTs”/non-scrollable dropdown list problem. When I turn off my second monitor and boot the software using only the main monitor (i.e. one monitor), Dorico 4 works as expected and clicking the dropdown list under the Track Inspector > Routing actually shows all of the VSTs I have in the VST Rack Tab. Hurray! As soon as I turn on my second monitor - the issue shows up again.

I cannot fathom a reason why this would be an issue on my machine, but hopefully this might help others troubleshooting with a similar problem. :+1:

Thanks everyone for your suggestions!

1 Like

Yes, this is indeed precisely the reason why you’ve been having problems. The issue is that Dorico is setting the height of the drop-down to the overall height of the “virtual desktop” described by the total geometry of all of the displays, and if the display where Dorico’s window is located is vertically smaller, then the menu will go off the top and bottom of the display, in a very unhelpful fashion.

My colleague Andrew and I spent a good chunk of today working on this, and he’s come up with something that should behave a lot better in this kind of situation. This improvement will arrive in the next update, a few weeks from now. Sorry again for the inconvenience in the meantime.

3 Likes

Fantastic! I look forward to the update. And for confirmation, my main monitor is indeed smaller (32" 1440p) than my secondary monitor (43" 4k for video playback), which seems to confirm the “virtual desktop” quirk.

I really appreciate your willingness to investigate (and solve) this quirk so quickly - even when it seemed to me that I was the only one having this particular issue. That speaks volumes about you, the Dorico team, and your commitment to creating the best user experience & notation software available. Thank you!

1 Like