Track mute doesn't grey out track

Hi - I am finally getting my head around Cubase 10.5 colour schemes, which I found very confusing in recent upgrades and switched to working in Logic as a result (I’ve had both for some years, Cubase, in fact, for 32 years). In Logic, when you mute a track, all the parts in that track are greyed out, which makes sense.
However, in Cubase that’s not the case, unless I’m missing a setting somewhere. Why is that? Did Cubase used to do it, i.e. in previous versions but not in the latest version?
Has anyone else been bothered by this? Ideally, the user would have complete control over ALL the colours and shading, etc. So, I’ll be interested to hear what other users think.

Cubase uses greyed out on a track to indicate that the track is disabled, which isn’t quite the same as muted. I think the track is bypassed in either case, but disabled is more than that - no disk activity or processing at all. Maybe it’s even purged from memory except for a place-holder stub. When you enable the track, it takes a moment for it to come up. Un-muting a track is much more responsive.

So the meaning of greyed out is already taken. Still, you have a point. It might be nice to have a more obvious indication of track muting.

This seems to be a bug and not a feature.
Cubase 10.5 shows data in a muted part (so you think you did not mute it at all) and has some other issues when muting or unmuting single parts.
In Cubase 10.0 this did not happen.

Some weeks ago I phoned the Steinberg support team and they took notice of that and called it an issue.