Track Quick Controls will not work at all

Hello, I am trying to set up track quick controls and for the life of me, it just will not work. I have a Roli Lightblock and I want to be able to control my 3rd party effects plugins from various vendors such as Output and Soundtoys from my lightblock. My goal is to set it up for each plugin and save it as a QC preset appropriatly named so I can simply load it up and control my favorite parameters from each plugin from my Roli. I’ve watched every video and read every forum imageable to figure this out but it just will not work.

In my Roli Dashboard, I’ve configured my lightblock to be on Midi channel 3 and adjusted just the first 4 faders to be on empty midi CC’s (CC3, CC9, CC14, and CC15). In Cubase, I’ve set up the Track controls accordingly and selected Roli Lightblock as my midi in. Then I loaded up Portal in an audio insert, pressed QC learn mode, and pressed the “wet/dry” fader in Portal. It was successfully added to QC slot one and when I move the fader in portal, it moves the slider in QC. HOWEVER, when I move the first fader on my Roli, nothing happens. What am I doing wrong?

Keep in mind, I’ve also tried this on other midi controls and the results are the same.





your Quick Controls settings seems to want to listen to Midi channel 2 - shouldn’t’ that be Channel 3?

p.s. Any reason you haven’t set your Quick Controls configuration to also output midi to the Lightblock and also to Receive AND Transmit?

Sorry, it must of not have saved and I just took a screenshot without looking. But it is on the propery channel now and it’s still not working. Do quick controls require certain midi CC channels? I mean what else would prevent this from working? Am I missing a step? I normally just press QC learn, click the fader in Portal and try to move my slider on the Roli. Do I have to press the slider on the Roli first or something?

To my understanding I don’t need to set it up as a generic midi controller correct? I have midi Channel 1 set on my Roli to do all midi learn with virtual instruments and it works perfectly, so I know my Roli is connected.

Is your controller set to the same channel as you selected in the quick control setup?

If that MIDI channel is ok (i.e. set to 3), everything appears to be ok to me- did you ‘learn’ the MIDI CC’s inside the track controls screen (screenshot 4), rather than setting them manually? If you learn them it’s a little more robust in my experience.

It may be worth just putting a midi monitor in the MIDI FX section of an instrument track, and confirming which messages your Roli is sending.

You may need to just set the quick controls MIDI input to ‘none’ to ensure they come through to the track though, as i think quick controls get intercepted before going to the track itself… Can’t remember 100% though.

I figured it out! The flags were on relative instead of recieve. I didn’t even think to look there. I appreciate everybody’s response.

1 Like