Track Splice Causes Click


I’m breaking up a large song into three pieces with CD track splices. When the pieces are reassembled in a DAW, or played in sequence, there is a small click at the transition (just talking wav files, this hasn’t been burned to a CD). When zoomed in at the sample level it looks like wavelab is forcing the final sample of the previous track, and the first sample of the upcoming track, to zero. This causes a discontinuity and hence the “click.” I’ve tried placing the splice at a zero crossing but it’s impossible to do so for both left and right simultaneously. I don’t remember every having to think about zero crossings for splices with other versions of wavelab. What am I doing wrong? Version 9.1.0

Thank You,

See the attached screen shot. Bottom file is continuous without track splice marker. Top is two tracks split by splice marker. You can see that the audio is identical before and after the “red box” but at the splice, it’s all gone screwy. I’m using master rig on each track in the montage and L2 in the master section for final limiting and dither.

I hope someone can help !



I ran a test with a simple 440Hz sine wave, you can clearly see how the last sample is forced to zero.
Screen Shot 2017-08-23 at 8.44.22 PM.png

Maybe hit “z” and that disarms snap to zero crossing … then look for a section of the program around those frames that looks promising and experiment with placement of the splice marker. Hopefully, you are not expected to also have this as an “even number” (ie xmin x secs 00 … a request I sometimes receive from record labels).

Yep. Classic issue with many plugins.

I’ve developed a workaround to basically never see this issue again and it involves:

Render the “Whole Montage” as a continuos file. You can tell WaveLab to Copy Markers and create new montage from resulting file when you do the render of the Whole Montage.

Then you end up with a new montage with all your plugin effects printed (and no glitches), and most of your original project data and decent starting point again. You may need to repopulate CD-Text info depending on your workflow.

Now you can render continuous WAV files of each audio track and when you line them back up in a DAW or media player to test, you will have seamless playback as you want. You don’t even have to worry about zero crossings. I worry more about marker quantization so that my DDP masters perfectly match the WAV masters than I worry about zero crossing and track IDs.

You can decide to dither on the “Whole Montage” render, or wait to dither until you render the individual tracks. I find that the MBit+ dither running on the montage output effects doesn’t cause this issue so that is safe to run on your second rendering of tracks, but definitely more intense plugins will cause issues with gapless playback if you render one track at a time. This is because as silly as it sounds, the plugins need “warm up” time and when you render a WAV of each track, it’s a lot of starting and stopping of the plugins. Best to print all effect in a continuous render of “Whole Montage”.

I personally do the initial render as 32-bit WAV and then apply dither later when I do the individual track renders so it’s easy to make 24 or 16-bit WAVs from the same “Whole Montage” render. Keeping the first render as 32-bit float prevents you from being locked in.

This is an issue that has been discussed but not yet fixed.

As a test, try this same process but with no plugins involved and I think you’ll find that the issue is not from the track splice, but rather a plugin being used and trying to render gapless/seamless audio from CD tracks.

When zoomed in at the sample level it looks like wavelab is forcing the final sample of the previous track

Do you use plugin processing at one stage? If yes, why do you say WaveLab is doing this? (WaveLab does not change samples when splitting a montage clip).
Please describe more accurately your procedure.

Check out my second screenshot (8.44.22). This shows the issue beautifully, there’s no plugins involved here at all. Just a 440Hz sin wave broken into two pieces with a splice marker. That last sample before the splice is being dropped to zero…why?

Thank you all for your time!

I can only imagine a drawing issue here, if no processing has happened.
Please open that clip in the audio editor, and watch the end.

I tried to reproduce, but could not.

Those screen shots look like they’re from Reaper (?). I think if you load files of continuous program in Reaper, you can pull out the clip edges and it’ll show start from beginning of file again, so I think Reaper is probably complicating this. I think your render files probably would look (and sound?) fine loaded back in a Wavelab montage, maybe?, as PG said.

But the first 10 or so samples of the 2nd file in your first screenshot looked messed up, so I don’t know what that’s about.

Good catch Bob.

Maybe you could upload the test tone renders for others to analyze?

Thanks Justin. It freaked me out the first time I saw you could drag out the clip edges in Reaper and the song would start all over again, because I’d never seen anything like that before.

To try this myself, I tried making CD track render files in Wavelab from a continuous sine wave, and opening them in Reaper, and I get exactly the same display that cparsons07 does. I had thought Reaper was adding an extra sample at the end that shouldn’t be there, but I don’t think that’s the case.

I made 2 regions on the same original full length sine wave in Reaper, rendered those regions having the renders automatically added below, and the display is the same, with the wrong looking last sample (see attached).

But I don’t hear a click from this one sample visual weirdness, when playing through the transitions in Wavelab or Reaper with any of the files. I think both programs are making and playing the files correctly, it’s just Reaper is not displaying the last sample correctly. My guess is Reaper is displaying the last sample “wrong” because it might have to, since you’re able to pull the clip edge out and have the song start all over from the beginning. Maybe they could fix the display, maybe not.

Try it if you have the time.

btw, the Reaper renders, that look “wrong” in Reaper, look correct when loaded into Wavelab.

Also btw, Reaper is forcing the display of the last sample not to zero, but to the level of the first sample in the region. Which in some cases will be zero (like if the region starts with silence) but not always. In my example it’s not zero it’s going to.

But back to the version with plugins, I can confirm that will probably render with quite audible clicks, if rendered to Regions / CD Tracks. Probably depending on the plugin settings.

440Hz sine at -3.
Master rig with factory preset AM Acoustic Country on Track.
Steinberg Compressor with factory preset Backing vocals 1 in Master Section.

I guess the only way to do that without clicks is as a whole montage render first, as Justin suggested.

In the screenshot, top is the original, bottom are the renders.

Yeah, I do a fair amount of live albums or albums that have crossfaded songs so I did some extensive testing on this at one time. I determined there is no issue with WaveLab when no plugins are used, and I can even use MBit+ Dither on the montage output safely and still render WAV files of each CD track that appear and sound seamless.

The issues happened when adding nearly any plugin to the clips and/or montage output effects. I noticed the problem never happened on DDP renders, only renders of individual tracks.

With the help of PG we determined that many plugins need a “warm-up” time and because DDP is considered one long render, the issue didn’t happen.

Because of this and my goal of never having to deal with this issue again, I developed a new workflow that involves first rendering the the “Whole Montage” to print all the FX to a single 32-bit float WAV. Then I can tell WaveLab to create a new montage from the resulting file and copy markers along with some other little tricks to expedite things.

Now I have a new montage with the plugins safely rendered and I can easily double check. All I add is ether 24-bit or 16-bit dither as needed and then render my master WAVs or DDP.

It’s one more little step but now I don’t even think about it because I can do it very fast and 2nd nature. I also like that I can verify all the plugins properly rendered without issue. Not just in the song transitions but in general.