Translation issues in instruments (related to auto text)

I use Dorico 3.1 in Spanish but I like to put instruments in Italian or other languages depending on what I’m writing. However, when the instruments are in my score, they look this way:

Clarinetto en Bb

That “en” is Spanish, not Italian, so I think Dorico forgets to translate that word in the instrument.

Related to this, it would be nice to show the tuning in German, as Tchaikovsky used to do. Maybe it’s possible, so I would happy to know how it’s done.

I think it’s related to the autotext that puts the tuning. Are we able to change or modify it?

I may be wrong, as I was with the spelling in some instruments, so I would appreciate any solution to this little problem I have.

Contrabbasso seems to be the recognised spelling in Italian: see https://it.wikipedia.org/wiki/Contrabbasso .

You’re very right, so it was my mistake. The same with the controfagotto. I’m sorry about this. I deleted from the main post as it was my mistake :frowning:

However, the problem with the “in” and the “en” is an actual problem.

Of course, as in English the word is the same, it works fine, but not in Spanish (we use “en” instead of “in”). Do you know any workaround apart from changing the language?

Hi reztes!
I’m used to writing the whole transposition stuff directly myself (I switch the transpositions labels to never and edit the labels with the transposition details exactly as I want them to appear). This could be a good workaround for your issue.

One problem here is that the language of the word “in” for the transposition of an instrument will use the language the application is running in, and not the language chosen for the instrument names on the Language page of Engraving Options. We’ll try to fix that up.

More generally there remains a whole other piece of work for us to do to make sure that the way the transposition itself is described is appropriate for the language the staff labels are set to use.

Thanks for the answers and suggestions :slight_smile: