Transport buttons keylab 61 mkII don't work within cubase pro 11

Hi,
Just bought a Arturia keylab 61 mkII for integrations with my cubase pro 11.
Alle midi seams to work ok, vst are shown in cubase, learning cc works but when hitting the transport buttons on the arturia a sound is triggerd instead of de transport functions.
Does anybody know this issue? operating system windows 10. Tried several remode devices (mackie control, mackie hui) but I presumed integration between arturia and cubase shoul be plug and play?

perhaps these screenshots will give you some clues.
In the “Midi Port Setup” section of “Studio Setup”, is there a separate entry for the transport buttons of the Arturia, such that you can choose to uncheck the box “In All Midi”.
Those transport buttons have to be removed from the “all MIDI”… and then setup to control the transport (see how I’ve done it for my M-Audio Axiom in the second pic.)


Hi, so you had to manually assign the controller within cubase?
I will try that to figure out how it works, in mean while also waiting for arturia support, because normally there’s a already made protocol wich should work immediately without manually putting it within studio setup.
Thanks so far

I’m curious to see what you find out. I feel like whatever Arturia offers, it’s probably something to do with configuring these same settings… automatically, I presume.

I’m interested in upgrading my controller myself, and I see the key lab has some nice features.

Well, they say look at KeyLab MkII - Tips & Tricks KeyLab mkII FAQ (arturia.com)
But for cubase you have to select the mackie hui I think, but has only 2 buttons available ?
Second picture i followed you hint.
on the arturia I preselected in DAW mode the Cubase template, but transports won’t work.

Yes, I Bought this one because alle the contollers, but it’s my first time experience with a midi controller (and only 5 months with cubase)


The Arturia instructions say to select Mackie Control… not Mackie HUI…

In the second pic, you don’t want to deselect BOTH of them. You want the KeyLab to play MIDI notes using the keyboard, but NOT using the transport controls. But I don’t know if deselecting one of those will fix the problem.

BUT… maybe you don’t need to do any of the above and just follow the Arturia instructions closely regarding the “Mackie Control”, and that will fix everything.

Tadaaaa… grinning:
Ok Shagazulu, Thanks!
By first attempt I did select the Machie Control, but it didn’t work, maybe because the in All MIDI was selected. I immideately started searching Forum and read that Cubase uses the Machie HUI instead, so started tryin everything with this setting…didn’t work.
Now I did selct the MAckie Control again and It’s working, transportbuttons, faders, knobs I think you would like this Midi controller to! I go playing wiht it and will brief you about my experiences If you’d like?

that’d be great. I’m interested to see how you get on with it.

So, you have deselected BOTH of those “in All MIDI” checkboxes that relate to your Arturia? It seems like you might only need to deselect one.

If you go to your MIDI track, or your instrument track, whichever you’re using, and you go to the area where it says to select your Midi Input… did you select Arturia Keylab there? Because that’s what you will always have to do UNLESS you allow the Arturia to be “In ALL MIDI” by checking at least one of those checkboxes.

you’re right, thes are my current settings. So I unchecked only the MIDIN2 because that one is used by the Mackie control.
I wired both the USB and the 5-pin DIN midi’s. USB to computer directly Ad 5-PIN DIN in/out Steinberg UR22mkII. Don’t know both are necesarely, but its working!


Both aren’t necessary, and that’s probably why you were getting the transport to play midi notes, I’m guessing.

If you detach the MIDI cable and just use USB, does the “MIDIIN2 (KeyLab mkII 61)” entry go away completely, and therefore its “In ALL MIDI” checkbox doesn’t need to be unchecked?

Still functioning, also with the cables unplugged.
Arturia support did advise me to reset preferences within Cubase also and put the global controls in manually as suggested on their site. Functioning very well. Now starting to discover al possibillities. First impression? Faders and transport controls are ver time saving.

1 Like

very cool.
I’ve used controllers in the past, and i found I just ended up using the mouse and computer keyboard still, mostly. I do have little Steinberg device that I use to control monitor switching in the Control Room, and source switching But the transport buttons I programmed on there, I don’t use. I don’t even use them on my keyboard controller in front of me since I have to reach for it. The computer keyboard is just too handy. So, placement is key to getting the most out of your new toy. Enjoy!