Transport control with keith mcmillen 12-step

Hi,
I want to use keith mcmillen 12-step footcontroller to remote control the transport functions in cubase 8. How can I set it up? I need to map note numbers to cubase commands. How can I do it? Any tipps?

Hi,

Open Devices > Device Setup. In the top-left corner, click to + button, and Add Generic Remote Device.

Then select MIDI Input port and click Apply.

Then enable Learn, select the 1st row of the upper table, and press the 1st footpedal. Select 2nd row and press pedal 2, etc. This way, it will learn incomming MIDI data.

Then go to the lower table. Select 1st row and select the command, you want to control via this pedal. For example Transport > Device > Start.

Please search for Generic Remote in the Operation manual or here on the forum, to find more details.

Hi Martin,
thank you very much. I will check it out.

I tried it but I was not scuccessful. I tried all Inputs I have. I didn’t connected the MIDI Out. The 12-Step Controller is connected via USB. Is that a problem? See my settings.
06-03-_2016_19-08-34.png
06-03-_2016_19-05-20.png

Have to excuse my poor German understanding ( :blush: :slight_smile: ), and also the fact that I don’t actually know that particular foot controller, but, in Screenshot #1, (btw, did the MIDI Learn appear to work, i.e. did you see the values in the Generic Remote window change? If, as I am guessing from your report, the Foot Controller is supposed to be transmitting Note-on numbers, then it didn’t happen :wink: ), from what I can see in that screenshot, all line entries would seem to be set to Controller number #7, on MIDI Channel #1 (“Adresse” is in fact the Controller number, when “MIDI-Status” is set to “Controller”)… If indeed your foot controller is transmitting MIDI notes, then “MIDI-Status” should be set to “Note On”, “MIDI-Canal” to the same MIDI channel as transmitted, and “Adresse” set to the appropriate MIDI Note number.
And i would also recommend that you set “MIDI-Eingang” to “12Step” rather than the current “All MIDI Inputs”.

Hi Martin and Vic,
thank you very much for your help. Controlling Cubase with my keith McMillan 12-Step footcontroller works perfect now.

Hi Nikon!
Believe it or not … I ran into the same problems trying to hook up my 12 step with Cubase 8. In my case, I see the Midi signals changing the parameters and I also see a signal every time I hit one of the keys, but none of the above settings show any form of activity.
I followed along the detailed description but it does not seem to work in my hands.
12 Step is connected via the Midi expander through a Saffire Pro24 into Cubase 8 Elements. Any ides. Thank in advance … in Deutsch geht natürlich auch :wink:

Cheers!

Hi 8Ball,
da das das englische Forum ist, hier in englisch. See my attachement of my settings. I hope that helps.
Best regards,
Niko
Einstellung 12-Step in Cubase.png