Transposing: Selecting all notes

I was supplied with this Dorico file with the score in the key of C. I want to transpose this score from C to Bb major.

When I try to select all the music by selecting a portion and then using Shift-Command-A, some of the notes are not selected. Therefore they do not get transposed. I think all of the black notes in the boxes I’ve drawn in this screenshot are the ones that are not transposing (including what I’d call hybrid notes, where notes in two different voices are on top of each other, I think).

What might I be doing wrong that prevents me from selecting all the notes?

Also, since I’m not very adept at this, if there are specific settings in the transpose panel that I should you, please let me know.

Thank you!
Eric


10.02 DORICO Christ Arose_LT (chg to Bb maj).dorico (1.2 MB)

Just click command+A to select all.

2 Likes

I suspect that using “Select more” over some notes on upstem voice 1 does not select any other voice, which is both predictable and useful. Select all is the tool you want to use.

I use ctrl-A and it selects fine. I’m on SE if that matters.
they all just became orange.

You can also use the system track to select all.

Thanks, everybody!

Apparently, my tendency to use Shift-Command-A (Select More) rather than Command-A (Select All) is the source of the problem. When I used Command-A (which I don’t think I’ve ever used, for some reason), it seemed to work.

And @lafin’s idea of using the system track to select all is another thing I did not think of.

Thanks to everyone who chimed in.
Eric

1 Like

Selecting with the system track is useful when you need to include system objects such as meters, key signatures, chord symbols, system text, etc. For transposing just notes, Select All is enough. (For this case you’ll want to add a B♭ major key signature at the start.)

If you want to transpose the entire piece (including the key signature), you don’t need to select anything. Make sure nothing is selected, then go to the Tranpose menu to make your transposition selections.

2 Likes

Won’t this first option in Write > Transpose also do the same as manually changing the key signature at the start? That is how I did it, and the key signature changed.

To make sure nothing is selected, I learned that the shortcut is Command-D (same as Edit > Select None).

1 Like

As long as the key sig is selected, yes! I had forgotten that Select All also gets the system objects. (Also, I hadn’t looked at the Dorico project, and from the screenshot one can’t tell whether there’s an actual C major key sig, open key, or possibly no key.) Sorry for the confusion.

1 Like