Treble Clef 8 below with parenthesised (8)

I’m engraving a piece for choir where the whole choir occasionally sings in unison, but obviously with the men an octave down. I’d like to condense this on to one stave, but with an octave down treble clef with parentheses around the ‘8’ (U+E057 gClef8vbParens in SMUFL). Is there a way to use this clef in Dorico? Not a major problem, as it’s pretty obvious what’s going on with a standard treble clef, but would be nice to have.

In the attached zip file is a file called userlibrary.xml. Put this in your user-level application data folder; on Windows, this is %APPDATA%\Steinberg\Dorico; on Mac, this is /Users/your-username/Library/Application Support/Steinberg/Dorico.

Now when you start a new project in Dorico, you will find the clef you’re looking for in the Uncommon category in the Clefs panel in Write mode. You can’t enter it via the popover, but you should be able to enter it using the mouse.

Unfortunately this new clef won’t appear by default in existing projects, but you can copy and paste it from a new project into your existing project.
gClef8belowParensClef.zip (1.71 KB)

Brilliant, thanks… was fully expecting this not to be possible!

One slight issue though - I had to change the XML to set ‘staveIndexFromBottomLine’ to ‘2’, and the ‘hotSpot.noteName’ to ‘G’. As supplied the clef put notes on the wrong lines (I suspect it thought it was a C-clef!). (I also changed the name to ‘Treble clef (8 below)’ for consistency with the other names.) It all looks OK now, but I’d be grateful for confirmation that I’ve changed everything required.

It does appear in existing projects after a restart of Dorico, so that’s even better!

Thanks once again.

Yes, that’s all correct – thanks for fixing my stupid mistakes. (In my defence, it was late at night!)

No problem - easily done, and easily fixed.

Thanks for your help.
:smiley:

Fred,

I know this thread is already 4 years old.
I used Daniels userlibrary.xml File, changed the relevant bit as suggested to:

<clefDefinitions>
		<entities array="true">
			<ClefEntityDefinition>
				<name>Treble clef (8 below)</name>
				<entityID>clef.gClef8vbParens</entityID>
				<parentEntityID/>
				<inheritanceMask>0</inheritanceMask>
				<basicClefType>kGClef</basicClefType>
				<clefTranspositionReminder>0</clefTranspositionReminder>
				<compositeID>comp.gClef8vbParens</compositeID>
				<clefCategory>kUncommon</clefCategory>
				<clefChangeCompositeID/>
				<clefDefinition>
					<isPitched>true</isPitched>
					<requiredNumStaveLines>5</requiredNumStaveLines>
					<staveIndexFromBottomLine>2</staveIndexFromBottomLine>
					<hotSpot>
						<noteName>G</noteName>
						<octave>4</octave>
					</hotSpot>
				</clefDefinition>
			</ClefEntityDefinition>
		</entities>
	</clefDefinitions>

and put the file into ~/Library/Application Support/Steinberg/Dorico 4.

I still get a different result: the clef appears fine under “Uncommon Clefs” - but if I put it into the staff it ends up on the middle line and behaves as a C3 clef:

1 Like

You might also just change it through Music Symbols…


1 Like

Thank you NorFonts for your suggestion!
I don’t want to replace the g8 clef with the bracketed one (I know I could replace another unused one), still Daniels suggestion to add the missing key to the userlibrary.xml has it’s own charm, as it is not a workaround…
I just have to get the values right in the .xml file to make the Treble Clef with parenthesised (8) work perfectly - and wonder, which they are…

It is the bit <staveIndexFromBottomLine>2</staveIndexFromBottomLine>
In the panel on the right the new clef is showing on the 2nd line from bottom line - but in the actual stave it shows up on line 3 - and is working like a C3 clef:

What happens if you change that value to 1?

Incidentally, you many not want to over-write the existing userlibrary.xml file, which may contain other settings, like default Paragraph Styles.

What you can do is change the ending to .doricolib, and place it in:

/Library/Application Support/Steinberg/Dorico 4/DefaultLibraryAdditions

e.g. not in the User settings folder. I’m afraid I don’t know the PC equivalent.

Dear ben,
I will try your suggestions. So far I had no own userlibrary.xml file at the chosen location, so that was fine with me - and once I have the xml clef area setup correctly, I can paste it into possible other user settings - or use your suggested folder.
There seems to be a setting/value for the display of the clef in the panel - and another one for the actual place in the 5 line notation staff. And two values with how the clef actually relates to the pitch. I am no expert at .xml files, just going by try and error.

[edit] changing the value to 1 does not change the misery, have a look at this sad little clef (it also change the C to a B…)