trick for exporting Sibelius xml files with technique text

I discovered that Sibelius xml files opening in Dorico did not export technique text such as ‘arco’, and ‘pizz’.
I tried putting the tech text into the sib file before exporting as expression text, but didn’t work, however, decided to try lyric text, and this worked.
However, if you put ‘arco’ or ‘pizz’ in your Sibelius file, it won’t play back as technique text in Dorico, so I just went through and checked where the text was and added the correct tech above.and clicked on the imported lyric text and hit delete. I did find that markings such as marcato and staccato did transfer though, so that was good. I have not tried out all of those markings yet. To make the tech. text stand out so you could notice it, I put on caps lock and made the lyric text in capitals.

Just thought I’d share this in case someone was having a similar problem.

p.s a while back when I opened sib xml files, all the notest were unbeamed, and googling this found this from the Sib forum:

In Appearance -> Engraving Rules -> Beams and Stems, please ensure that “Optical beam positions” is selected before attempting any MusicXML export.
http://www.sibelius.com/cgi-bin/helpcenter/chat/chat.pl?com=thread&start=690290&groupid=3&&guest=1

Just in case anybody else is also searching for this, I’ve found a different trick I think is simpler. Just use Sibelius’s “Find and Replace Text” plugin to replace “pizz.” and “arco” with “piz.” and “arc” (or PIZ. and ARC or whatever, just mis-spelled things) — Dorico will import them as Shift-X text objects (as long as you have the right Dorico XML preferences set in the Preferences dialog box). Obviously you still have to go through and replace them all, but if you’re dealing with a large score, this is a lot faster than manually creating lyric by lyric.