Trigger midi command by hitting key command

I would like to know if it is possible to trigger a midi command (like it would come from a midi controller) by hitting a key command. Like a virtual midi controller which can be controlled via key commands or sth. like that?
There are some functions in cubase which are only accessible by using a midi controller, but I would like to use the keys on my (PC) keyboard without needing an additional controller, taking away space on my working space.

Is there a way? Or has anybody an idea for a workaround?

Keyboard Maestro will do this and much more.

https://www.keyboardmaestro.com/main/

Bome Midi Translator can do that, and MIDI-OX which is free does it too.

Could not really get it to work with either one…
When you are working in Cubase the key commands do not get sent to those programs, even if they are opened behind it… they need to be on top of the desktop to get it to work, which is not really convenient.

You really tried Bome Midi Translator? :wink: https://www.bome.com/products/miditranslator

Yes, when I was inside Cubase the event monitor of bome was not showing any activity when I hit a key command… As if Cubase would not let that through. Is there any specific setting I missed?

I don’t know what you set up, so that’s kind of hard to answer.

Tested it again: It is working in with every other application on windows. Only cubase does not let those key commands through to bome midi translator, it suppresses them.

I took the standard settings, and configured a “Note on” command, i.e. C#5 on my “+” key of my keyboard.
If I open a VST instrument inside Cubase, put bome on top of my desktop and hit “+” it works. As soon as I put my focus in Cubase, so that bome is still opened but behind it, and hit “+” theres no activity on the midi translator and also no sound coming from my vst instrument. So it does not have anything to do with the command I set up. It seems that cubase is the culprit here!

Do you have Release Driver When Application is in Background enabled?

How is it routed?

I would need to see the exact config with all details to help further.

Do you have Release Driver When Application is in Background enabled?
No it is off.

As I want to a keystroke to be my trigger, I assume I don’t need any routing and enable only my midi output.

On my Instrument track in Cubase I have “All midi inputs” selected.

Now if bome is opened on top, Cubase is opened behind it in the background and I hit “+”, bome’s event monitor gets a “Keystroke in” and a “midi out”. Now I hear the note C4 coming from the instrument in Cubase. As soon as I put my focus on the Cubase window though, bome does not get a “keystroke in”/“midi out” anymore and as expected: no sound coming from the instrument in Cubase.
So I assume the routing is fine, otherwhise I would not hear any sound coming from the instrument in Cubase?

When Bome is opened on top (and cubase behind it) and I hit “+”

When Cubase is opened on top (and bome behind it) and I hit “+”:

As soon as Cubase gets the focus, no keystrokes come through to bome’s midi translator :unamused:
When I am surfing with my browser or working in Outlook/Office or any other program on my computer, bome always gets its keystrokes, even if it is not on top of the desktop.

Now I tried something with my little midi controller. If I active my midi controller in bome’s midi inputs, no matter where bome is opened (behind or in front of cubase) it always gets the “midi in”. It really seems to be only an issue with the keystrokes.

I’m stumped. Your settings are correct, but I can’t reproduce that here. I even had the same translator set up as a tester. See the animation attachment.

A couple thoughts though- have you tested different keystrokes? On my system, in Bome, there is no ‘+’, just “Num +” and Shift (=). (So I used the letter A)

And of course, test in an empty project in Cubase Safe Start Mode (or hide the User Settings folder from Cubase)

Maybe redundant to say, but for precision in troubleshooting worth mentioning- The issue is that the Bome cannot capture the keystroke when Cubase is in the foreground.

Oh, okay, wtf…
Tried to start Cubase in safe mode with an empty project, but does not work either :frowning:
Well I guess there is something wrong with my PC then, thanks anyway for your Time!

Just an idea: Is it perhaps the case, that those keyboard keys are not getting through, which have Hotkeys assigned in Cubase?

Hm… what happens when you test the theory?

Can’t test it, as I have Bome not running here. Am using Midi-Ox, which is midi-only (to the degree I know). No PC-keyboard keys.

Just checked the key commands in my settings of Cubase Pro. The keys “NumPad+” as in TJ99 example and “a” as in your example have key commands assigned. Or did you use “A”? It has no key command assigned. Does Bome differentiate between “a” and “A/Shift-a” "?