trill issues

I’ve got a trill problem. My preference is to use Tr without a wavy line for untied notes, with a wavy line for notes tied. In the latter case, the wavy line would extend to the right edge of the last note included in the trill (this is standard practice in some style manuals, though not in Gould).

My problem comes about when a trill is going over a system break. In that case, Dorico forces a new tr mark. I want ONLY the wavy line. There seems to be no way to remove the tr on the new system. I scoured properties and options, but could find nothing.

A secondary issue is that when the trill bumps into the system-start measure number, there seems to be no way to move the measure number out of the way.

Here is an example of what I’m talking about. These trills began in the previous measure and continue on to these tied notes.

Does anyone have any ideas about how I can get what I want?

David Froom

In Engrave, can you click on the measure number and in the bottom panel, use the X or Y options to change its position? (or use the option to hide it).

Actually, no, not in my scores – the X or Y options in the property panels to change measure number positions doesn’t work. I didn’t try hiding it (and replacing it with a text using shift-x). Weirdly, if you go to Engrave and select a measure number, it simultaneously also selects the most recent time signature, and moving via x or y options in properties moves the time signature!

If you were able to move a measure number, please let me know how, and maybe post a .png to show?

‘Bar number X’ is the property you should adjust. You can also nudge the selected bar number with alt+arrow.

Thank you!!! That works. I hadn’t noticed this because it appears under “time signature.” I should have looked more closely.

Does anyone have suggestions about the trills?

David Froom

I’m afraid there’s no way to hide the trill continuation at the start of the new system, but I will make a note of this and hopefully we’ll be able to implement this in future.

Thanks, Daniel. To be clear, I’d like to have the wavy line on the new system, but without the cautionary tr.

Daniel – a follow up. I checked with Gould, as you said in another correspondence that her book was one of the leading guides you use. She recommends, for trills over a system break, either:




Right now, Dorico doesn’t allow for any of these three. I find Dorico’s system break tr continuation, without parentheses or preceding wavy line, to be confusing, as it trips up the eye, making it think a new trill has begun.

I tried fudging this by telling Dorico not to use the wavy line at all, then putting it in using an alternate articulation. Unfortunately, I couldn’t match the look of the trill wavy line.

Thanks again, and I do appreciate you having this on your notes for future fixes.

I’ve got a workaround! Unfortunately, it’s not an in-Dorico workaround, and it’s also not a very good or wise general approach to solving Dorico issues. That said, for some people from now until when certain functions and features get sorted out, it can be a rather powerful tool when there’s literally no other solution.

If you have access to Adobe Acrobat or some other program that can edit pdfs, it’s a super easy fix. Simply finish the piece as you would, leaving in the trill the way Dorico wants to do it. Export your pdf. Open in Acrobat. Erase the tr. Save.

Other things you can do in Acrobat that can be useful here and elsewhere:

  1. Move things around.
  2. Rotate different items by any angle.

Daniel, is this still planned?

I would prefer to get only the extension line w/o the “tr” after system breaks. Please make this possible.


Please see below:

Is this in 2.2.10 ? Great!

already available (2.2) -> Engrave -> Engraving Options -> Ornaments

I believe in 2.2 only two options are provided, though; the third is new for 2.2.10.

all the three options are already available in 2.2.


Dear mati,
You’re right! That’s the kind of third option I’d like to see for pedal lines :wink: