Trills Not Working in Panel Mode - Version 5 BUG?

I’ve just upgraded to Dorico Pro 5, and cannot get trills to appear in my score in “Panel” mode.

I click on the Trill symbol in the panel, and the cursor changes to an arrow with the “tr” symbol attached. But when I click on a note-head, nothing happens. Moreover, I cannot get rid of the “tr” symbol other than by selecting something else.

Am I doing this wrong, or is it a wee buglet?

PS - just to add, Windows 11 … and FWIW, all other ornaments I’ve tried work exactly as expected. Just not trills!

I certainly find that I’m able to create trills as expected via the panel, Brian. You should also find that you can do it using the Shift+O popover by entering tr and hitting Return.

Hmmm - how strange!

Seriously, for some reason, when I’ve expanded the “ornaments” panel, and click on the “tr” symbol at its top left, I get the expected cursor, but it doesn’t do anything when I click on a note on the score. All of the other ornamentations I’ve tried, work exactly as I would expect.

What DOES work, is using a pop-over.

I wonder what’s going on here?! I am using the very latest version of Dorico 5 Pro, downloaded and installed from scratch just yesterday (May 30th).

OK so I’ve figured out how to restore the cursor by pressing Escape, but Panel-originated trills are definitely not working here!

What version of Dorico are you using? For me (D4 on Win10) tr is bottom left!
Click it and apply to a note… and it works perfectly (as does the shift-o tr popover)

My Baroque / Classical panel looks like this; I’ve clicked “tr”, as you can see, and I get the “arrow with tr” cursor, but it does not do anything! All the other ornaments work instantly, as do dynamics, time signature changes, etc. Specifically, NOT trills!

Hi Janus - sorry, you asked which version - Dorico 5 Pro, version 5.00.10 / 30th May 2023.

I’ve uninstalled my version 4.0, so can’t check it (short of re-installing it). But from memory, I am pretty sure it did work when I tried it. For assorted reasons, I did my last two big projects in Finale 2005 because I was under time pressure, and had not yet learnt my way around Dorico sufficiently to feel confident.

No worries. I’ve not upgraded yet (waiting until the routine niggles get sorted before doing so) so it might be a D5 issue.

Try selecting the note and then clicking tr in the panel.

Hi Derrek, I’ve tried that too. That panel button just gives me the Trill cursor, but does nothing else. Popovers work, so I can still add trills - it’s just frustrating because it’s slower doing it that way.

This does appear to be a teething-trouble bug in version 5; I just hope it gets picked up by the dev team and fixed!

Daniel, just wondering which version of Dorico you were using when you said the Panel Trill works?

I’ve recently updated to 5.0.10 (30 May 2023) PRO on Windows 11, having first uninstalled my Dorico 4 PRO system, which I hadn’t used much because shortly after buying it, I got a couple of time-critical projects, and did them in Finale 2005, with which I am very familiar.

I think the trill thing DID work in version 4, but literally can’t remember, because it was many months ago I last used it.

This is the version of the Panel that I have in my system, and as you can see, I’ve selected the “tr” button, but apart from giving me the “tr” cursor, it literally does nothing, even though all the other ornaments (and things like dynamics, time signatures, etc) work as expected.

I just tried it, and it works fine for me.

Hi Derrek,

Was that with Dorico 5 Pro, version 5.0.10, on Windows 11, which is what I have?

If so, I wonder what could be wrong with my brand new installation?

Windows 10 (64-bit)

Sorry to hark on about this one, but I have done some more investigating.

This morning, I reinstalled Dorico 4 Pro, and the TRILL works exactly as documented in Panel mode as well as Pop-over mode.

The exact same sequence of keystrokes and mouse-moves/clicks in Dorico 5 Pro, does NOT!

So unless there is some strange user preference/setting that needs tweaking, this is a bug in the current version of Dorico 5 Pro.

What’s the best channel to report this as an issue?

hi Janus,

This morning I reinstalled Dorico 4 Pro for a while, and can confirm that in that version, the Trill works exactly as expected/documented. But not in (my installation, at least of) Dorico 5 Pro.

Which is very frustrating! :frowning:

Alas I don’t have Windows 10 to hand any more, having upgraded to 11 a few months ago.

I don’t think the version of Windows is the problem. What you report sounds as if you have opted to “load” your cursor with the trill symbol in order to apply it to multiple notes.

What happens if you select the note, and then click on the tr in the panel?

That’s the second easiest way (after using the popover); with ‘loading the cursor’ the third.

However, they all work for me.

Also: F2005? really? :astonished: