Triples on drums bug?

I have some troubles getting a very simple eight note triplet-fill on drums done in Dorico

The uploaded Screenshot shows what I want to create (3 triplets on snare, 3 triplets on Tom1, and so on)
If I use my MIDI-Keyboard for note entry I get a weird note-chaos when trying to write Tom 1 = e’’ on the Keyboard.
My second attempt was to enter one bar of triplets just on the snare drum and move the note heads to the right position with MAC keys “option”+“cursor up/down”. This doesn’t work either.

Could anyone please help me what I am doing wrong?
Thanks in advance,

I made a Screen-Capture for demonstration:

This is what I am trying to write:

I can replicate the issue but I have no idea whether it’s specific to or something that the team are planning on addressing at a later date.
After you’ve typed the three snare triplets, either type the shortcut to end tuplet, followed by the shortcut for tuplet then 3 then Enter (on an English keyboard that would be Shift+; ; 3 Enter, and on a German keyboard it would be Shift+Ö Ö 3 Enter), or click the triplet button again. Then type EEE. Rinse and repeat.

Thank you Pianoleo!

With your method I can enter the triplets fine, but you have to get it right at first entry.
If you change f.e. Tom1 on e’’ with “option”+“cursor up/down” afterwards the triplet chaos strikes back again :wink: This has been a bug/feature from the very first Dorico version (at least I don’t remember any version where triplet drum fills weren’t a complete nightmare)

Yes, unfortunately when inputting drum notation using the MIDI keyboard, tuplets do cause this kind of problem. This is on our backlog to be addressed in future. In the meantime, if you can input the tuplet runs using the computer keyboard rather than the MIDI keyboard you should find things go a little more smoothly. I’m sorry for the inconvenience.

Thanks Daniel!
I will wait patiently :slight_smile: