triplets in 3/8?

I am writing in 3/8 and want the rhythm - quaver, quaver, triplet semiquavers. And for the pattern to repeat in following bars.
When I enter the triplet at the end of the bar a triplet automatically appears in the beginning of the next bar. Remove the unwanted triplet at the start of the second bar and the one in the previous bar disappears too. They are inextricably connected as far as I can tell.

See attached file.

i assume this is a bug and can’t think of a work around. Re-notating in 3/4 isn’t an option as it is updating an existing score.

Help would be gratefully received.


Dorico 2, Note-performer 3, Mac Pro
Screen Shot 2018-07-07 at 9.06.50 AM.png

You need to type 4 before you type the triplet, or, as you’ve discovered, Dorico creates a triplet of three quavers (eighths), not three semiquavers (sixteenths).

This is not a bug; this is design.