Trouble arranging MIDI in Cubase le 8

I’m finally diving into the world of MIDI and while I’m getting the hang of it, I keep hitting some stumbling blocks that aren’t addressed in any of the tutorials I’ve come across. Namely, the issue I need help with the most is: I’m trying to arrange drums using HALion SE, and in all the tutorials, people just click in the boxes of the piano roll with the pencil tool and it neatly fills in the whole box for a particular note. However, when I click with the pencil tool, it only fills in part of the box. I have to neatly draw in the whole box to get the same effect and that is WAY too tedious for me. There has got to be something really simple I’m boneheadly overlooking. I’m also aware of the MIDI drum editor, but I’d like to be able to figure out the regular MIDI thing first. I would really appreciate any help, as well as tips and tricks that would be useful for me :smiley: . In the future, I’ll also need help figuring out how to modify individual drum sounds, if at all possible.

Hi and welcome,

I’m not sure if I understand your question completely. Could you attach a screenshot what happens and what you woukd expect?

For the Drums, I would recommend to use the Drum Editor. It’s the same “MIDI” as it is in the Key Editor. I would also recommend to use Groove Agent SE instead of HALion Sonic SE for the drums.

Here is a video showing what I’m expecting (skip to 3:15) https://www.youtube.com/watch?v=5mWz1WavKzA&t=9s

…and here’s a Screenshot of what I’m getting.
Screenshot (4).png
Yes, I know the drum editor is better for drums (obviously), but I’d at least like to get a hang of the key editor first.
Yes, I know Groove Agent is better for drums, but my version of Cubase only came with HALion, so I’m making the best with what I got.

Hi,

Is it the grid the problem here? If you want to change it, click to the 1/64 in the tool bar (next to the iQ button) and set it to 1/16 or 1/8.

Sorry the video is pretty long, what exactly do you point to?

In the previous post I said to skip to 3:15 on the video. As you can see, one simple click fills in the entire box for a note. For me, despite the fact that I have “snap to grid” turned on, all the marks I make with the pencil tool, as you can see from my screenshot, seem to place notes irrespective of the grid or any quantizing or anything. The where a drum hit begins and its duration is determined by where I click my mouse and whether or not I drag it. I just want to do individual clicks to fill in whole boxes in the grid like at the part I mentioned in the video I linked

Ok, sorry, I overlooked the jump time.

There are 2 parameters. One is the Grid. By this, you can define where the note starts. The 2nd parameter is Length. It’s next to the Grid. And yours is also set to L 1/64. You can set this to follow the Grid (Quantize) or make an independent settings (as you have).

So to solve your issue, at L (Length) to follow Quantize) or to 1/16 or 1/8 or 1/4 or what length do you want to. I how this is it. :wink:

Thanks! That solved the problem.
I just started using the drum editor too, and it seems I’ve run into another roadblock. Whenever I try to assign a drum map, I get no sound. What might be causing this?

(Also, I’m new to the whole forum thing :unamused: . Should I start a new thread for this topic? In my mind this is still pretty related and odds are I’ll be coming back for more advice concerning both the key and drum editors and how they interact)

Hi,

I would recommend to make a new thread.

Double check the Drum Map settings, please. Make sure, the notes are not muted. And make sure the MIDI Channel is set up correctly. As far as I know, by default it’s set to 10. Choose Any our 1. Choose 10 only of the sound shots on the MIDI Channel 10.