Trouble connecting keyboard

Hi!

I’m having trouble connecting my keyboard to Cubase. My keyboard isn’t listed in the MIDI Device Manager. Does that mean it won’t work or is there a ‘generic’ Midi option that I should select?

My keyboard is a CHROMATONE (it’s MIDI): http://chromatone.jp

Any expertise would be greatly appreciated - I’ve been trying to solve this on my own for weeks - thanks :slight_smile:

Why would it be listed in the device manager ???
If you plug the midi in and you get a signal saying your recording them its working , the device manager is designed for templates of COMMON used keyboard sounds to be listed in the inspector and i hate to say … ive never heard of your keyboard …
Search the internet for a device manager file ,otherwise … your on your own :wink:

Yes, go to device setup

  • click the plus symbol
    -select generic remote
  • midi input/output should be your keyboard (or midi interface port of your keyboard)

You also need to change settings in the “quick controls tab” in device setup
-select your keyboard as the midi input
-make quick controls clicking the learn box and wiggling your control
-in the selected vst, rightclick your desired knob or whatever and assign to quick control#1-8

Let me know if u need more help:)

edit: I just saw that in v7.5 there are Track Quick Controls and VST Quick Controls now (instead of one QC tab)
I couldn’t find out what the difference is yet (so I made a new thread) but you want to probably use the Track Quick Controls)

If this is a midi keyboard connected by a USB connection (can’t tell by the link provided) to a Windows based PC just make sure it is connected to the computer prior to starting Cubase. Cubase will not recognize it if it is connected after starting Cubase.

If this was the problem please show your support for this “issue report”

http://www.steinberg.net/forums/viewtopic.php?f=184&t=55869


Regards… :sunglasses:

its midi in/out…
no usb…

Then you need to be looking at your MIDI port and forget about looking for your keyboard. Set your midi track to the MIDI port your keyboard is plugged into. The rest basically has already been said in earlier posts.
If your still having problems then please state your problem more concisely, including descriptions of what you have already done if applicable.

Thanks, ggc, Prock and BriHar.

Unfortunately, I’m still stuck. I cannot find the word “track” or “midi track” anywhere in the Device Setup. Perhaps Cubase 7 doesn’t use the word “track” anymore?

I have set up a “Generic Remote” in Device Setup and it’s “MIDI Input” options are: All MIDI Inputs or USB 2.0-MIDI Port 1. It’s MIDI Output options are: USB 2.0-MIDI Port 1 or USB 2.0-MIDI Port 2.

I’ve tried many configurations but whenever I go to the “Key Editor”, my keyboard doesn’t play the notes, I still have to mouse click on the Key Editor’s keyboard with my mouse.

Thanks for all your help and sorry for the late reply.

I checked out your link, unfortunately (for most of us) a lot of the info is in Japanese so we really need a lot more detail where relevant.
Is it connected to the computer via a USB cable or two MIDI cables ? (from what I can gather it is the latter)
If it is MIDI cables, then what are they plugged into? I assume (from your previous post) that this is some sort of USB MIDI interface (name? model?). Remember your Keyboard MIDI out must go to the MIDI In port and the MIDI Out of the Port (if you’re using the Chromatones internal synth) goes to the MIDI In of the Keyboard.

I see it has a headphone output and appears to have built-in speakers, but I can find no mention of a Line Out connection, only an Aux Out. Assuming it can indeed produce it’s own tones, and assuming you want to record these, then you will need to dedicate an audio (mono or stereo as appropriate) track for this.

If you wish to control a VSTi, then we really need to know your MIDI setup. As I alluded in my previous post, you need to set the input of your VSTi or midi track to your MIDI interface Port - this is what the DAW sees - not your keyboard directly.
I suggest you first try to get a simple VSTi going, using the CHROMATONE as controller before anything more complicated. (FYI: If you do not intend using the Chromatones internal sound engine, then setting up an “External Instrument” is rather pointless.) Remember to you will need to set the local (echo) on/off setting both on the Instrument and on the track

Have you read the “Setting up MIDI” chapter in the Operation Manual?
The more information, details pictures etc. you provide, the fewer questions need to be asked, and the quicker we can help. Up to now it’s all a guessing game and questions. Perhaps give us a detailed step by step account of your procedure.
BTW that is one strange keyboard ! :wink:

SOLUTION: "Remember your Keyboard MIDI out must go to the MIDI In port and the MIDI Out of the Port (if you’re using the Chromatones internal synth) goes to the MIDI In of the Keyboard."

Thank you, thank you, thank you BriHar and everyone else who tried to help correct my epic n00b error - The keyboard is now playing through Cubase - now the fun can begin =D

Thanks, this resolved my issue :smiley:

Glad to hear…
Just so you know… this behavior has been fixed in newer versions of Cubase. If I remember correctly it was fixed starting with CB 9.

Regards :sunglasses: