Trouble transmitting MIDI commands to Cubase LE4

Hi!

I’ve been trying to transmit MIDI commands through a Tascam US-122MKII to Cubase LE4. So far, I’ve been unsuccessful. Here’s what I’ve done so far:

  • Secured connection between MIDI device and the MIDI-interface (the Tascam device mentioned earlier). Connected MIDI-interface to laptop. I’ve tried using a Yamaha PSR-270, but couldn’t transmit any MIDI-data.
    Now that I’ve connected my Roland Gaia SH-01, I know it’s not the connection between the MIDI controller and the interface: the SH-01 has Active Sensing messaging enabled, so it’s constantly sending data. The MIDI In light on the interface flashes with regular intervals, and pressing a key makes it flash, too.

  • Tried for hours to get Cubase to recognize the MIDI-interface in the first place. Turns out downgrading my driver from 2.0.3 to 2.0.2 did the trick. Having done that, I went to Devices -> Device Setup and set the VST Audio System to “US-122 MKII / US-144 MKII.” According to MIDI Port Setup, under the same window, the MIDI interface’s MIDI In line is active. “Good!”, thought I.

  • VST connections changed automatically to Tascam US-122 MKII / US-144 MKII.

  • Checked out the MIDI Device Manager under Devices. This is where I got very confused. When I click “Install Device”, I get this enormous list of devices I don’t happen to have. Therefore, I hoped to have any luck defining a new one. “Define new…”, I clicked, naming the new device “Gaia SH-01”, assigning (clicking on?) channel 1. This, however, seems to be solely for Midi Output, so I don’t think this is very relevant or important.

  • Created an Instrument Track, selecting “Tascam US-122MKII MIDI” as input routing and a VST instrument to be controlled. Pressed “Record Enable” and tried to record.

  • Wept salty tears.


    That’s as far as I’ve gotten. Any help would be very much appreciated.

My computer runs Windows 7 Home Premium SP1, 64-bit. I…I’m not sure what else you would need, but I’ll be happy to supply additional data.

You don’t need midi device manager, as you found out.
Check what midi channel your synths are using, and set the instrument track’s midi channel accordingly.

Thanks for the quick reply! It’s just…I’m a little embarassed to ask this, but how do I check what midi channel my synths are using? Is this a matter of trial and error, or is there some way to see this directly?

Look to your synth’s manual. You could also set the Instrument Track in Cubase to recieve Any MIDI channel.

1.You can´t set MIDI channels on instrument tracks at all
2.MIDI and instrument tracks do receive on any channel anyway, unless filtered somehow.

Alright. I set up all the devices again tonight. I don’t think I did anything differently–but for some reason, it works like a charm now. Thanks a lot, though. I’ll be sure to check this thread again if tomorrow brings the same problems.

Oh lol, busted!
Maybe I should use instrument tracks before commenting on them :wink: