Trouble with Tokens and deleting pages

Great! This is a kludge at the moment because it is not simple to do with master pages, as layouts have varying total page counts.
At the moment I go through changing the numbers on every page.

Thanks for quick replies, I will try the flow-specific tokens tonight. 2 more questions:

  • How can I delete unwanted pages?
  • How can I change the Master Page without it adding another page to the flow?

To delete unwanted pages, right-click the page you want to delete and choose Remove Overrides.

To make it such that you don’t get an additional page at the end of the flow, you’ll need to remove the MA frame chain from the default master page: as long as it’s there, Dorico will continue to believe that it needs to create extra pages at the end of the flow to fit the music in.

Is there no way to simply delete a page? For some reason my project just created an additional ten pages at the end (I don’t know what I did to it). Remove Overrides isn’t working as a way to delete them. They don’t have overrides to begin with, and that isn’t coming up as an option when I Right-Click the page (i.e. the symbol in the Pages panel).

dirtalley, it sounds like you’ve done something very very strange to your master page, probably involving music frames that aren’t in the MA frame chain.

Can you zip up your project and upload it here, or at least take some screenshots of what your master pages look like in Engrave Mode (with frames turned on)?

Here it is, all zipped up. Thanks for taking a look!
Songbook1.dorico (733 KB)

Firstly, let me apologise - you DID zip up your project and attach it to the first post; it’s just that by the time I read post #11 (possibly a few days later) I’d forgotten!

This one’s simple, I think:

You’ve given Dorico 13 flows, but only a couple of them actually contain notated music. The remainder just have an empty placeholder bar, but Dorico’s still seeing that as music that must be displayed. You can override that by going to Setup mode, selecting your “Full Score” layout (right side), and then unticking all the flows (bottom panel) that don’t contain music.

Thanks for looking at it! It was worth re-attaching it anyway, because the problem of the many extra pages hadn’t appeared when I made the original post.

I tried unticking all the non-music flows in Full Score, and it did work to get rid of the extra pages, but it also emptied all the bars of music I had written after the first page. I’ve attached another zip file of it in that state, so you can see it…something to do with the frame chain?

All the non-musical pages were made with the Text master page I set up, which doesn’t have a music frame in it. So maybe I should not have made separate flows for those pages?

This is my first time using Dorico for something like this (combining music and text pages), and I clearly don’t have a good understanding of Flows and Frame Chains and Master Pages. Can you suggest a better way to set this up? I don’t mind starting over, I can just copy/paste everything into a new project. The idea was to have each “song” be a separate entity, but have them all in one project so I can print them all together, make it into a PDF, etc.

Ah ok. I see what’s happened.

Basically your music frames are all MA (Master) so Dorico is going to try to place each flow on a page, in the order that the flows are written. If you go into Galley View (bottom right corner of Write Mode) you can see that your actual music is in flows 1, 2 and 3; NOT flows 1, 6 and 10. This is why when you deselected flows 2-5, 7-9 etc. your music got deleted.

You’ve got two options:

  1. Cut and paste the music from flow 2 to flow 6 and from flow 3 to flow 10. Then untick as before.

  2. Cut and paste the music from flow 2 to flow 6 and from flow 3 to flow 10. Then go into Engrave mode, turn the Frames switch on, and in the top left corner of the first music frame click the drop down next to where it says “MA”. The “unlink”. Then click the dropdown next to “Flows:All” and just tick the flow that you want to appear on that page. Rinse and repeat for the other music frames.


I was reading the thread on how to delete unwanted pages at the end of scores. See attached.

The problem was, when I went to Page 15 and selected to delete the overrides, my first two pages were also deleted in the process. (MY title page and instrumental layout pages were deleted and a valuable part of my project naturally)

Can someone walk me through this process so not to delete anything of value, except for the empty pages at the end?

Thank you so much,


Amanda, we probably need to see your project (rather than a screenshot of some blank pages and some overrides) in order to work out how you’ve got where you are.

Make sure you select in the Pages panel only the page whose override you want to remove, and in the right-click menu choose Remove Page Override(s) and not Remove All Page Overrides.

Thank you Daniel…I am happy to say that did the trick…great!

Hi, thanks for all the help so far. I finally got back to work on this today - Pianoleo, I couldn’t figure out how to cut and paste the music to different flows, like you suggested, but I just moved the music pages themselves back to the beginning.

At this point, I just want to delete the extra pages at the end (Page 15 onwards). They got created somehow and I want to get rid of them, so I can export the rest of it as PDF without them. They don’t have overrides so the Remove Overrides trick won’t work - and when I tried doing stuff to them to create overrides, so that I could hit that button to delete them, it just undid whatever I’d done and didn’t remove the page.

How can I get rid of them? It’d be great if there was a way to just delete pages! :slight_smile:
Songbook1.dorico (740 KB)

The cut and pasting is best done in Galley view. You’ll have to count through manually to see which flow is which, but it’s really just a case of grabbing something within the music on-screen, doing Ctrl-X (Cmd-X on Mac), scrolling to the other flow, selecting the first rest and doing Ctrl-V (or Cmd-V).

Jeff, to remove those unwanted pages at the end of the layout, go into the master page editor, edit the ‘First’ page pair, and delete the MA music frame from both the left- and right-hand pages.

Thanks Daniel, that worked to delete the pages. Pianoleo, yes I see what you mean. I changed the order of the pages from Engrave mode, which had the same effect, but I understand now how to do what you were talking about.
Thanks for the help!

Can someone pls show me how to delete the final page (page 24) in this project? I’ve tried everything already mentioned in this thread, and I am stumped. It seems not to behave like the other pages

I re-attached the file with this post. Thnx!
Jeff (1.21 MB)

Go to Engrave mode, select page 24, right click and then click “Remove Page Number Change(s)”. Then select and right click page 24 again and click “Remove Master Page Change(s)”

Master Page Changes are overrides shown with a green line at the top.
Page Number Changes are overrides shown with a purple bottom-right corner.

ANY overrides mean that Dorico hangs onto the page, even if it’s empty.

I notice that putting the flownumber token in a page header for a part will print, but the flowtitle token will not show if the first flow for an instrument is a Tacet (for reasons explained above). Is there any chance that this will change in the foreseeable future so that flowTitles for a page beginning with a Tacet will fill their token without the need for page overrides?

EDIT: Never mind: I found the Layout option to force the Flow Title token to show.