Trying to add extra stave not attached to another solo

Sorry about this - I must have missed something.
I want to add an extra stave (it so happens beneath an existing Horn stave).
Following the ‘help’ instructions I add the extra stave ok but the player-label “Horns” is now centred between the original and added stave, as if it imagines I want to split the Horn part.

I want an entirely separate instrument/player/line but can’t find a way to make it independent so I can rename it with the instrument I want.
Any advice would be gratefully received.
Thank you.

What is the underlying meaning/purpose of the extra staff?

If it’s a separate instrument entirely that you only want to show for some bars: add another instrument for it in Setup mode, input the notes you want in the bars you want on that staff, and allow empty staves to be hidden. You can control empty staff visibility on a per-layout and also on a manual basis.

If you want to add an alternative way of playing a few bars for the Horn, you could add an ossia staff instead.

Hi and thanks for the response.
I’m editing a midi file pulled in by Dorico.
I just wanted to add an extra instrument to the entire score having re-thought the scoring.

I tried adding an extra solo player (in the “players” list at the left of set up mode. That was fine but it located the new stave at the bottom of the score. I tried moving it up to where I wanted it but it stubbornly stayed at the bottom of the score.

So then I tried “adding an extra stave” and set it just below the original Horn part. As I said the stave added. It hasn’t automatically been braced to the original Horn part or the bar lines extended down, but I can’t rename it as it’s somehow otherwise attached to the horn whose label is centred between the original and new staves.

Here’s a picture

If moving the new player in the left panel in Setup mode didn’t change the order of staves in your full score, is there perhaps a custom player order set for the layout?

Yes, I had to adjust the “custom player order” with the imported score. Oh crikey, don’t tell me! I rechecked it but it only showed the new player but now I return to it, the whole list is revealed. I see the player at the bottom of the list.
And…I can move it into position.
I’m really sorry I wasted your time. A lesson learned though.
Thank you for your help and hints.

It’s possible that previously you were viewing Layout Options just for the new player’s part, which naturally only contains one player.

Instead of adjusting the custom player order, so long as you don’t need a different order in the score than is set by the list of players in Setup mode, you can simply deactivate it so the score follows the order of players in Setup mode.

Just by un-ticking the “use custom playing order”?
Nice to know, if so!
I’ll try that.