Trying to export one Piano MIDI and one Guitar audio track to MP3

I watched several Cubase videos but with no success so far.
Just the Guitar audio track shows up in the new audio track created using Elements Audio Mix Down. Thank you very much if you guys can help me to do that.

Hi and welcome to the forum,

My expectation is, you are using external hardware (digital) piano, right?

You have to connect its output to your Audio Device’s input. Then you can either:

  • Record an Audio track of the piano. Or…
  • An an Audio track and enable Monitor on the Audio track + export in real time.

In any case, you have to get the audio signal (in real time) somehow to Cubase to be able to export it.

Hi, please I still need your help me on the following problem. Sorry to bother you again.

Problem: Using Cubase Elements I recorded a piano track using MIDI but I can’t hear the track using the audio system.

I also recorded an audio track playing guitar and I can hear it.


I’m using a Roland Digital Piano FP-3;

The Piano is connected to a PC using a Roland USB MIDI Interface UM-ONE;

The PC is connected to a Icon Duo 22 Live Sound;

The Duo 22 Live is connected to a Roland KC Amplifier.

In the Cubase Studio Set Up I have the MIDI Port Setup and the Audio System configured.

I only can hear the MIDI track if I connect the Piano physically to a Behringer Xenyx502 and them connect it to the Roland KC Amplifier.

I understand that is the reason I can’t save the MIDI track in the MP3 format as I reported in my last e-mail on June 9th, because the MIDI is not connected do the Duo 22 Live.

Many thanks in advance.

Thanks again.

Best regards.

Caruso, 55 11 99986 1892


You have to connect the Piano’s Audio Out (Line Out) to your Audio Device’s Line Input.

Many thanks Martin for the reply!

I did that using File, Export, Audio Mix Down, MPEG1 Layer 3, Interleaved, Create Audio Track, Real Time Export and Export Audio but with no success.

I also clicked on the track Monitor option during the process (I also pushed the Mon button in the Icon Audio Device).

The new Audio Track is empty. The MP3 file doesn’t have the piano MIDI sound.

I’m sorry! What am I doing wrong?

Best regards,

Caruso, 55 11 99986 1892


Please first record the audio of your piano to the Audio track you have created. Once you have the audio, you can export it (no Monitor at the given Audio Track then, please).

Hi, I’m back with the same doubt! LoL! But it is good! I’m using Cubase Elements to create my original songs database and I’m happy using audiotracks!
The issue is I can’t save my project (guitar, voice and Roland FP-3 midi track) into a mp3 file format; Cubase saves guitar and voice tracks but not the midi one). Roland is connected through my sound device as you guys warned me. Using real time export, monitor, etc. Something is wrong! May be my sound device configuration? Thanks in advance for a new information


Could you please attach screenshot of the Project window, where we can see the Audio track’s Input and Output and also the Audio Connections > Input window screenshot, please.

Hi, please let me know if the screenshots I sent on Monday helped you to understand what I’m doing wrong.




I’m sorry, I don’t see any screenshot in the thread.

Hi Martin, I have just uploaded the screenshots I sent by e-mail. Please let me know if you received


Where is the MIDI Track routed to? What is the output, please?

I’d like to mix Audio 1 (guitar), 2 (voice) and Mid 1 (Roland piano) tracks into a mp3 file. The tracks 4 to 9 are tracks created by Cubase using the Export/Audiomixdown but the mp3 file doesn’t have the piano sound


Unfortunately, we still don’t see the output of the MIDI Track. But my expectation is, you send it to the Roland piano.

I expect you have already connected the cables from the Roland’s Outputs to your Audio Device’s Inputs.

Then you have 2 options:

  • Record the Audio Track of the Roland to the project. Then you can export it the same way, you do it so far. Or…
  • Add an Audio Track as the Roland Monitor, enable the Monitor on the track and export in Real Time.

Thanks Martin!
Please see my comments in red on your e-mail below.
Caruso, 55 11 99986 1892


I’m sorry, I don’t see any comment.

You probably sent it from email, which seems to be not working this way.

Thanks Martin! What you mean about “the output of the MIDI”; probably this is the problem; how can I set this? You mean send the output of the MIDI track back to the Roland? Yes I connected the Roland to the Audio device as you advised me last time! When I have just audio tracks (voice and guitar) in the Project both go to the mp3 file! but the MIDI track doesn’t go! I tried using Monitor, real time but with no success. I’m sorry!


How is the audio from Roland connected to your Audio Device, please?