Turning off Yamaha keyboard's native sound and only hearing outputted MIDI instrument

Hello. Complete newb here so apologies for my naivete. I’ve googled what I thought would be a common question but must be using the wrong language so trying to post here for help.

Using Cubase 12 Pro and a Yamaha DGX-670 keyboard. All I want to do is have Cubase’s sounds (i.e. HALion Sonic oboe) be the ONLY sound I hear when I play my plugged in Yamaha keyboard, and not both the HALion sound and my Yahama’s ‘native keyboard’ sound. I can hear both the ‘piano’ sound and the oboe and want only the oboe sound (for example).

This must be super easy and obvious in retrospect but I’m just not getting it. Thanks for any help.

Hi @Krister1

You need to turn off the sound on your piano itself.
Check the manual for instructions:

This might be the relevant paragraph:

Turning Audio Loopback On/Off

This allows you to set whether Audio Input Sound (page 95) from the external device is output to a computer or a smart device or not along with the performance played on the instrument. To output the Audio Input Sound, set the Audio Loopback to on.

For example, if you want to record the Audio Input Sound as well as the sound played on the instrument by using the connected computer or smart device, set this to on. If you intend to record only the sound played on the instrument by using the computer or smart device, set this to off.

The setting can be made via [MENU] → Cursor buttons [U][D][L][R] Utility, [ENTER] → TAB [L] Config1 → Cursor buttons [U][D] 2 Audio Loopback.

Thank you very much.

So I’m looking at that in my manual and as I play with it it doesn’t appear to make a difference to my ears. I set HALion to a drumkit to make it easy to tell the difference and as I play the Yamaha I hear both the drum sound and the native note, and this is true whether I set the Audio Loopback to On or Off. So it seems to be something else I’m missing.

Thanks again. :slight_smile:

I wonder if it’s bc I’m using the Yamaha DGX speakers for output for computer and keyboard. Would this be solved if I set my output speakers to anything but the Yamaha, such as my laptop? (Unfortunately I can’t see how to set my laptop to be the output in the Studio Setup of Cubase, it appears the Yamaha is my only option for Output).


Please switch the Local Control Off at your Yamaha.

Ok so a search for ‘local control’ gives no results in my DGX manual, but when I searched that in Cubase’s manual I followed the instructions on the page ‘Monitoring MIDI Tracks’ and was able to complete those, with no results for the solution I’m seeking. I also followed that to the entry for ‘ASIO Direct Monitoring’ where it says if the Direct Monitoring box is greyed out my keyboard might not be supported, and for me the box is greyed out. Not sure if that’s related and part of the problem.

So still not solved yet but I really appreciate the help so far. Thank you.


I don’t know if this is working on your instrument too.

But this video might be interesting for you.

I thought every midi keyboard had a local setting. Why don’t you turn the volume of your keyboard down.

Just pulled up the reference manual. By googling your keyboard. Look at page 79. Local control. Actual setting is at the bottom of page 80. You should have user manual. Reference manual and data manual.

Ah brilliant got it. I took all your answers and ended up on this youtube link (" Yamaha DGX-670 As A MIDI Controller" by ‘Piano Tone’) that shows how to turn off local control. It is not in the printed 100 page manual that comes with the DGX so even though I read the whole thing it wasn’t in there.

Thank you so much everyone. Now I can have some fun with my new toy. Have a great weekend.

1 Like