Two stave organ

I’m using the most recent upgrade to Dorico. Currently imputting a Mass by Jommelli from a set of instrumental parts, so beginning with a single stave for Soprano voice, adding notes, then adding a second stave etc., etc., I’ve virtually finished the opening movement, but when I select ‘organo’ (2 staves) no instrument appears. It will add a piano and a three stave ‘organo’. I don’t know whether this is peculiar to this version - I never tried in the earlier versions. I can use the 3 stave organ part of course - and if I do, is it possible to hide (delete) the unwanted stave?

[Just for info, using instrument names in Italian]

Ian Schofield

Have you considered (as a work-around) using a (2-stave) piano, renaming it as organ, and changing the sound to an organ sound in the HALion player (or your preferred VST)?

As far as I know, the option “2 or 3 stave” for organ is new in v. 1.0.30.
For me adding a “2 stave organ” works as expected.

Perhaps you should zip and upload your file for a closer look.

Thomas

That’s right: the new update has a choice.
organ.png

Thank you both. I had considered using a piano, and renaming it - I’m not bothered about the playback sound. I’ll have another go before I zip the file up.

Ian

Well, I just tried again and still no two stave organ appears. I did notice that when I selected the instrument, the ‘empty handed player’ (over on the left) became ‘empty handed player 2’. Now, just to be really basic, how do I get the zipped file attached to this message? (I function at a very basic level!!)

Ian

could it be that you instrument definitions file has become corrupted in some way, and thus not being replaced by the updater? I had a modified version of the file, and noticed that the 1.0.30 updater didn’t update that file. I just reinstalled Dorico and got the new instruments.xml installed. It works as expected, I can sucessfully select between a 2 and 3 staff organ.

You need a compression utility to zip up files… what OS/version are you on?

Thank you for your reply. I’m OK with zipping the file up. I just can’t find how to attach it to the message. The file in question was begun on 1.0.30, so I don’t think it was an updating of the file that is the issue. For your information, I’m using Yosemite.

When you choose “post a reply” you get a box in which to write comments, just below this, and below the “submit” choice you should see two tab "Options"and “Upload attachment”. Click on Upload and then use "choose the file to find it wherever you stored it and then click on “Add the file”

Thank you for your help Robert. Unfortunately, it won’t allow me to add the file because it’s larger than 2Mib. The original file was just over 90 bars long (2.8Mib), so I deleted most of them - leaving only 3 bars (2.5Mib). I have subsequently tried to add a 2 stave organ to a couple of other files and no joy there either. It seems likely that it is as Fratveno suggests, the instrument didn’t get added in the update.

If assuming this is the way to go, I re-install Dorico, should I:
Download the file again, then install and it will just overwrite the current installation.
Uninstall the current 1.030 and start again.

If either of the above are in the slightest bit tricky - I’ll stick with using piano and renaming it!

Further thanks for all the various suggestions.

I confirm there is something strange with the two stave organ.
I tried to add it and it did not appear. Instead the Bass Viola da Gamba player changed to Organ (but only in the Setup Mode). The staves do not appear in the score.

You should find that the ‘Organ (2 staves)’ instrument works fine in a brand new project. Is that definitely not the case for you?

It looks to me as if projects created in versions prior to 0.30 have the older instruments.xml definitions embedded in them…(?) [only instruments used in the project] and hence instruments from the the 0.30 definition file (even if present) cannot be added to those projects.

In response to Daniel’s question. This was a brand new project in the latest version of Dorico.

Interestingly, I started a new project, where the only instrument was a two stave organ - and that did appear!

I’ve now tried several times, starting new files and adding the 2 staff organ to older files (which had no organ), adding both 2 and 3 staff organ to the same file… and everything works as expected…

Very strange. I see from another posting, that I’m not the only one experiencing this issue. As mentioned earlier, this was a new project, but i also tried adding the stave organ to older files and it wouldn’t work.

I am having a similar problem: In Setup Mode the organ (2 Staves) would not show up. Instead a Viola da Gamba changed its name.
I can add a three stave organ, but not an organ with two staves.
If I open any other project, I can add the two stave organ no problem…

Please see this post for the solution for this problem.

Many thanks Daniel.