UI lag in mixer on macOS 10.13.6 and Cubase 9.5.40 with 4k display

I know there has been quite a bit of discussion around the UI lag topic on macOS. But I am not quite sure I understand what the latest situation is regarding this.

I am facing severe lag in the Mixer while scrolling left and right and occasionally also inside the MIDI Editor when editing multiple MIDI notes. The behavior is pretty strange.

To demonstrate what I am seeing, I have uploaded a short movie clip showing my on-screen experience.

Are other people here experiencing the same issue? If yes, where you somehow able to resolve it?

https://youtu.be/m_JpRQ7s4F0

I agree that there has been some lag in the GUI of Cubase 9.5, but after watching your video, I feel what you’re experiencing is very minor. That’s not to say you’re incorrect. :slight_smile: Either I am just accustomed to this small lag on my Mac, or this is the way Cubase was designed. It’s hard to say.

However, I do know when Cubase 9.0.0 was released there was major GUI lag — so bad that I couldn’t/didn’t even use Cubase 9 at all for an entire year until 9.5 was released.

Cubase on macOS: not a smooth experience. Frame rate is clunky. One hopes it will be fixed one day for a smooth “smartphone-like” scrolling experience.

Oh boy, ok… I already though I was hallucinating. I know there used to be a lengthy thread on this topic (UI under macOS in general not only 4k)… But it seems to have disappeared recently.

I found the topic in the archives and it appears it was locked down for some reason. Do we know why that is? Looks like it is still current.

I’m not sure, but I do hope it’s not being treated as ‘that’s just the way it is’

This is not minor. Also, the more tracks, the more lag you get.

I’m using El Capitan with a 4K screen. Every app that had a laggy GUI (when El Capitan was first available) has been fixed. Audition, Premiere, etcetera.
All except Cubase, which has gotten better, but its still not totally fixed.

It sucks.

Yes, it is a minor amount of lag. Did you use Cubase 9.0 on macOS? That had major lag and was unusable (for me at least). Is what the OP experiencing a show-stopper? No. It’s an annoyance. Does 9.5 have a small amount of lag which should be smoother? Yes. So the word “minor” is appropriate in this case.

What are your computer specs? I’m wondering why you’re getting more lag with higher track count (I don’t experience this). I’m not saying you’re incorrect, but could it be an underpowered GFX card or not enough CPU for what you’re trying to do?

I’m not using 4k monitors and have a super powerful Mac Pro, and I experience similar lag (maybe not QUITE as much, but still really bad). On other composer friends’ Macs I’ve seen the same thing with Cubase, and also when I checked it out at Guitar Center a few months ago just to see this exact issue. It’s really a drag and it makes Cubase feel very outdated and clunky. It might seem minor until you use any other DAW on the same computer and experience how fast and smooth these things are, and the difference it makes in feeling and flowing like a professional app should. Let’s hope they finally get their act together for C10.

Just installed 9.5.41. As kind of expected no change. :smiley:

Now in the editor I assume you could argue that the lag is somewhat OK. But in the mixer??? That is just unacceptable.

What I still not understand is why I have MIDI tracks which show considerable UI lag when editing multiple (!) notes at once and others which do not… They are otherwise completely identical.

Please don’t think I am against anyone on this issue. I highly agree that Cubase is not as smooth as it should be and once was. I use Logic equally as much as I use Cubase and I don’t really notice a difference (or, like I said, maybe my brain has just adjusted to Cubase’s lag).

I’ve used Cubase since v4 and have complained to Steinberg many, many times over issues they break or never have addressed despite being poorly designed, so I’d be one of the first to write to them about something behaving incorrectly. However, at the same time, through the years of using ANY DAW, I’ve also learned that most of the problems I have are definitely on my end — being a bad plugin, driver, conflicting application, etc.

So, for meradium, to try help troubleshoot your issue, have you tried a few steps to pinpoint if the issue really is Cubase or perhaps something on your computer causing this? A few things to try are temporarily removing Cubase’s preferences and/or starting Cubase in Safe Mode; create a new project and try loading the same set of instruments to see if the lag still occurs; create a new macOS user account and test Cubase in that account; if you have another Mac or someone with a Mac and Cubase, test your project.

Again, I’m trying to help find the issue and not saying anyone is delusional in the GUI lag. :slight_smile:

Perfectly fine. No worries. I have not yet tried the ideas you mentioned… but then again this is kind of a completely fresh setup.

My issues only started to appear once I got the totally shitty idea to get a 4k display. This seems to be putting severe stress on the UI of some applications. I remember when they first promoted the Retina displays my initial impression was that it was completely useless and only putting severe stress on the GPU… after x years though I thought they will finally have solved it. But it turns out this is absolutely not the case.

At least I have finally figured out what is causing the lag difference with the MIDI notes in my clip… If the count of selected notes starts to exceed a specific number Cubase changes the visual feedback. With a small count the notes are scaled with their full colored fill… result: LAGGGG. If the count increases it switches to a kind of transparent look where you only see white lines indicating the new notes position and length. This draws a million times faster.

Now the question is: Can Mac users have this less laggy display mode by default? :slight_smile:

Unfortunately, the mixer problem is not solved by this though…

On the other hand I have to admit that I probably also never had a template file with something like 400 tracks (MIDI and Audio)… So this count might also have a negatively impact. I am just wondering how people like Junkie XL can possibly run the MASSIVE templates they have.

He must use Windows and very likely has Steinberg helping him personally – as a film composer myself who has templates that are huge (but not nearly as huge as Junkie XL), it’s a very major issue. Doesn’t happen on Windows, and I think I remember him being on a Windows machine, though I could be wrong.

It could be possible using a 4K display causes Cubase on Mac to be more sluggish. This is where I cannot throw in my two cents because I am still using Apple displays from over a decade ago.

Concerning Junkie’s setup, he is running Cubase on a PC. I remember him saying he does but still loves the Mac QWERTY keyboard.

I can’t recall how large Junkie’s template is, but from my own experience, I am running about 2400 tracks and I, honestly, don’t seem to notice a difference in lag compared to running only a few tracks. So like I mentioned, try the steps I listed above to see if something is conflicting with Cubase.

Another thing to try is using the built-in macOS audio instead of your interface. If you have a badly written driver for your interface that could slow things down in Cubase.

There’s also the software called Etrecheck which can look for hardware or software issues in your OS.

Finally, look up Richard Ames video on YouTube about real-time audio processing and how it works. He explains that some hardware and software could conflict with the way a DAW performs.

I don’t use 4k monitors and I experience the GUI lag in Cubase. A couple of years ago I led the movement here to get it remedied, and we got Steinberg on board…but it’s unfinished for many of us it seems, though some things were fixed. I’ll try some of your suggestions, but I definitely won’t be using Mac OS audio instead of my Apollo 8. :slight_smile: Also, all the other DAWs I’ve used or tried on this same computer have no GUI problems like this, so it’s still on Steinberg to figure out why. (There’s no anger towards you at all in this post, just in case it gets misread! Your help is greatly appreciated).

I remember you bringing up the GUI lag issues in Cubase 9, and I fully supported it (and still do). :slight_smile:

Concerning the built-in audio suggestion, what I meant was to just try using the built-in audio temporarily and see if it makes Cubase react differently. I didn’t mean to abandon your Apollo altogether. This test will let you know if UA’s drivers are causing issues with Cubase, and if they are, you report to UA instead of Steinberg.

Another thing to try is switching your ports around where your Apollo and display(s) are plugged into. Look up the 2013 Mac Pro thunderbolt buses to understand what I mean. You want to separate the devices plugged into each bus so that one bus isn’t carrying a huge load of data while the other buses hardly have any.

I will try these suggestions – thank you for posting them. I didn’t know about the 2013 Mac TB port thing. I’m considering going to Windows because Apple has gotten absurd in many ways and everyone I personally know that has made the switch is very happy and not looking back, but if/until I do that I’ll try these things.

The lag is annoying, it did get better but it’s still bad. I’m using logic 10 for now on a 4K display with no issues.

Agreed… but at least it got a bit more usable…