Unable to access Cubase 12 website

When I try to access the cubase 12 site from the cubase homepage, the page loads briefly and
turns blank. The homepage works well but when I click on the cubase 12 menu, it turns blank.

It looks like it’s working generally…

Have you tried only with your phone, or have you also tried other devices?

I have tried ok different devices and computers. It has failed to work

Considering that there are no other recent reports of this, it might be something on your end.

Have you tried disabling Javascript (just for that website)?

I have tried and it hasn’t worked.

I have also tried using other people’s devices and it still brings the blank page. Could it be a region specific issue?

It does sound like it is, though not from Steinberg’s side they do not filter website requests, afaik

Have you tried using a VPN?


I have used a VPN and it’s now working. Thank you so much for the suggestion. I am truly grateful. Is it possible to escalate this issue to Cubase? I am currently in Uganda, East Africa.

1 Like

I don’t think it’s necessary to repot to Steinberg – the problem isn’t likely to be on the Steinberg side, it’s more likely to be some kind of misconfiguration along the route between your Internet provider and Steinberg’s website.