Unable to activate Halion 7

I purchased a crossgrade license for Halion 7 last weekend. I downloaded, installed as per the Download Assistant. BTW I’m using Windows 10.

However I’ve not been able to activate despite trying for hours and hours and hours.
The Activation Manager signs in to my account, and Halion appears in the activator, and the wheel at the bottom starts spinning and never stops. I have to close it down via the task manager.
I’ve uninstalled everything multiple times, reinstalled to no avail.
I’ve deleted everything at %appdata%\Steinberg\Activation Manager\ and anywhere else I could find it. All to no avail.

So the bottom line is I’ve wasted hours and not been able to use Halion 7.
The only Steinberg VSTs installed previously was Wavelab LE 9.5 and Sonic Se, both of which are now uninstalled.

Any help would be appreciated.
BTW I did raise a ticket with the Australian Steinberg ‘support’ but they only emailed back asking if I was able to sign in with the Activation Manager. I replied to them 24 hours ago but haven’t heard back…

Thanks, Belinda

Really? Nobody has any hints at all?
6 days now and I’ve tried everything. Deleted, reinstalled, signed in again using Firefox, Edge and Chrome, still no joy.
The Activation Manager is sending details to Steinberg and receiving details back, but nothing.


Don’t necessarily know the answer but one thought.

You said wheel was spinning but nothing completed.

As this was an upgrade could it be that the Activation process was looking for the dongle and eLcc to replace the Halion 6 licence? So the issue you are trying to troubleshoot is not with the Activation manager directly but with the functions of the dongle and eLcc. ie Is the USB port or dongle working OK

Hope you find a resolution soon.


Thanks Dave,
It’s a crossgrade from Falcon, so there’s no dongle or H6.
I think part of the problem could be that for the crossgrade I was given a new customer number, as I previously had the free Halion SE and Wavelab LE 9.
I don’t know… driving me crazy.

I don’t believe it but it just activated :joy:

I tried to open eLicenser and it came up with a Synsopos.exe error. Then by some form of black magic opening the Activation Manager worked and Halion 7 immediately activated. WOW…