Unable to copy from a stave

I’ve just come across a very odd issue where I am unable to copy and paste from one part, specifically the bass of a harpsichord part. This only happens in one flow. I have other flows in the project with the same instrumentation where I am able to copy and paste from the that stave without issues.

There’s not too much we will be able to help with without viewing your project.

Have you used Edit > Notations > Cross Staff in that section?

It might be worth a try to select the problematic bars and do Edit > Notations > Cross Staff > Reset to Original Staff. It might not help, but it has helped myself and others in similar situations where copy & paste has not behaved properly.

Fenaroli Partimenti, Bk 2.dorico (1.6 MB)
The problem part is in Flow 7, trying to copy the l.h. of the harpsichord to the cello part.

I was able to copy it by using Duplicate to Staff Below.

1 Like

That didn’t work unfortunately, but thanks for the suggestion. NB that was in relation to your first suggestion. I will try the second one now.

Here it is.

Fenaroli Partimenti, Bk 2 - copied.dorico (1.7 MB)

Yes it does.
Fenaroli Partimenti, Bk 2x.dorico (1.7 MB)

Select first note, Edit >Select to end of flow. Right-click>Paste Special>Duplicate to staff below

Janus and Steve Jones. Ok I’ve tried Duplicate to staff below. Then copied the new part back to the harpsichord. So that’s ok as a workaround. But surely there must be a way of finding out what has gone wrong with Copy & Paste in this instance (which by the way is only in this Flow).

Plus I am now getting another issue, which is that if I copy one or two bars at a time back to the harpsichord, the figures appear, but if I copy a line or more back, they don"t!

So I undid right back to where I started, and tried the Duplicate to staff function and this time it’s worked. I’d still like to know what happened to the Copy & Paste functionality in this Flow though. Thank you all for your assistance.

Try adding another harpsichord, then select all notation in both staves in the original one and paste into the new harpsichord. Try a copy and paste from the LH of the new harpsichord to the cello. If it works, delete the original harpsichord.

  • WARNING* - you will probably have to do this for all flows, or maybe change the players in each flow so that you do not delete all the notes in the other flows.

Added later:

One other observation - if you go into the Harpsichord layout and copy the LH notes, then go into the Cello layout and paste, it works. It seems like it is just in the score layout that the problem occurs.

Weird. It appears that Select to end of flow does indeed select correctly but does not paste into the cello part. But, this works: Select first note of LH Harpsichord, Shift-cmd-A three times, then copy & paste.

If I select the first bar in Harpsicord LH, and then with right click choose filter/note and chords it works with the pasting to cello.
It must be something in the figured bass that blocks the (normal) copy paste function… :thinking:

Hi Steve, I tried your idea and it did work. However I couldn’t face doing that with every single flow, and since the workaround of Duplicate To Staff Below also solved the problem I’ve decided to leave it as it is. It’s worth noting by the way, that this problem only exists in this flow, not in any others.

Christian, but surely if it was a figured bass issue it would the same issue in all the flows, but it is only in this one. Also of course figured bass can be selected to appear in any instrument if necessary.

I suspect the problem will be that some of the notes are crossed from another staff - this means that the staff they draw on has been overridden. Try doing Edit > Notations > Cross Staff > Reset to Original Staff before you do the copy and paste.

Anima.dorico (3.5 MB)
Does anyone have the answer to why I cannot paste into the part called “soprano”? (I use this part for cues on different staves in the parts)
Quick reply is appreciated very much!
Macbook Air, OS 12.6.7, Dorico Version

Try this:

In the Full Score layout, select the first note that appears in the Soprano part (at rehearsal mark 2).
In the properties panel (lower zone), uncheck “Starts Voice”. All the bars before that point should now have a rest in them.
Select the bar where you want to paste, activate note input (Shift-N or double-click), paste.

Now I figured it out: For some strange reason I had a -1 staff flag at rehearsal mark 18. (Even though it was only one staff, and it went on like nothing had happened) Deleting the -1 staff fixed the problem.
Thank a lot for looking into it, Steven! I should have specified that it was a bit later in the score the problem appeared.