Unable to import FLAC files (Solved)

Friend sent me some FLAC files he’s working on, to import into Cubase 6.5. Thought that it would be a breeze. It isn’t. Keep getting ‘Cannot convert this type of file’ messages whenever I try to import the files. Thought that the files might be corrupted so fired up Audacity. Files play fine.

Do I have to enable something in order to allow for the import of FLAC files? Curiously, I can select FLAC from the dropdown list in 'Export Audio Mixdown and save the file as FLAC. When I try to import this file, however, nothing happens. Not even an error message. Cubase acts as if I have select nothing for import.

Hoping that you guys can throw some light on this. I have absolutely no idea what’s going on. :confused:

Didn’t FLAC import arrive in Cubase 6.5? Anyway, if it won’t work, just convert them to WAV in some other program. Easy enough, and not really worth worrying over.

Are there hundreds of these files? Could your friend NOT convert them to FLAC? It’s a useful format, but not the ONLY one, and some people do seem to get religious over using it :slight_smile:

Use the official converter:

http://flac.sourceforge.net/download.html

it is simple, small and convenient.



I understand that I can convert them to WAV and then import those but tbh that’s a bit like saying save the files out as WAV and then convert to MP3. I can do both - was just hoping to do it from within Cubase. Seeing as they make such a song and dance about it when promoting the new features of 6.5. :laughing:

Not a biggie, was just hoping that there might be a simple fix, something that I was overlooking.

Thanks for repies. :slight_smile:

Still, something is not right in your installation. I mean, Cubase should at least be able to import its own encoded FLAC files… If it still matters, you could try trashing your preferences.

Well that’s kind of what I was thinking myself. :wink:

Not exactly sure what you mean by ‘trashing your preferences’? I Reset each section within the preferences to Default. Is that what you mean? or do I need to Delete each section instead? Resetting to default had no effect.

I have requested assistance from Steinberg tech support. The automated reply said that it might take up to 48 hours to receive online support. I will update here when i receive this. Hopefully, the issue will be resolved and I can post the fix here, in case anybody else suffers the same fate as me. :smiley:

https://www.steinberg.net/en/support/knowledgebase_new/show_details/kb_show/removing-the-preferences-of-the-sequencer/kb_back/2025.html

Fantastic! Thanks so much to both of you. That worked perfectly! :smiley: Still haven’t heard back from tech support but really just need to update them now. Thanks again guys. Really appreciate it. :slight_smile:

To get Flac working, make sure you project in NOT in 32bits.

Project -> Project setting (configuration du projet)
use 16 bits or 24 bits to import flac file.