Unable to load piano models in The Grand 3


The Grand 3 has been working for me until recently, when I discovered that none of the piano models will load.

When I try to load a piano model, I see small diskette graphics in the model selection pop-up menu.

I opened Steinberg Library Manager and found a triangular, red warning icon in the upper right hand corner.

Clicking on the warning icon opened a pop-up with a list of missing library files. They appeared to be associated with The Grand 3.

The files listed in the pop-up are the same as those in the folder “Content The Grand 3” on the drive with all my VST instruments, projects, etc.:

The files don’t appear to be missing, the drive is less than 25% full, and all my other VST instruments (e.g., halion, groove agent) are functioning normally. I don’t know what changed that caused The Grand 3 to stop working.

Useful pointers to resolve this problem would be greatly appreciated. Thanks for reading.


I have a similar problem. I had to reinstall all my software recently, and after installing The Grand 3 (as I was downloading and installing my other Steinberg products) the app opened fine, but nothing happened when I clicked on a model. I was able to “launch” a piano using the menu system, but then I got a popup saying that piano wasn’t installed (they all say that). When I checked Steinberg Library Manager, there was no tab at all for The Grand content. When I click “open” on the downloaded content, it opens the SLM but still doesn’t show up. I don’t do anything unusual in terms of change the default install paths or anything like that. Any ideas? On an iMac i9 with 64GB ram running Big Sur 11.6.5.

Hi Adam. Steinberg support helped me resolve the issue a couple weeks ago. I wish I could remember more specifics, but basically my sound library associated with The Grand 3 needed to be re-registered.

It’s still not clear to me why I had a problem in the first place. I purchased and installed the VST and began using it with no issues. Then, seemingly out of the blue, I could not load piano models. I asked the support rep if he knew how the issue surfaced and didn’t really get a straight answer.

Long story short, I can use the VST again. I’m happy. I encourage you to use Steinberg chat support if you still haven’t resolved your issue with The Grand 3.