Unable to open Lossless m4a in WL 9.5

Hi - I need to decode and open apple lossless m4a’s (alac). Generally, I batch convert the m4a’s to wav and work on them from there. I’m coming from 32-bit WaveLab 8.5 which works perfectly for this. Now, wavelab 9.5 just hangs when I try to open one. I have no problem playing the the lossless m4a files in WMP, and have the most recent iTunes/Quicktime installed. I’m on Win 10.

I have tried tried changing the file extension - .alac, .mp4, etc… same result.

I don’t understand why WaveLab 8.5 which is still installed has no problem with this, yet WaveLab 9.5 can’t do it.

Ideas? Thoughts?

FYI - here’s the MediaInfo entry on a sample file:
Format : MPEG-4
Format profile : Apple audio with iTunes info
Codec ID : M4A (isom/iso2)
File size : 27.3 MiB
Duration : 3 min 28 s
Overall bit rate mode : Variable
Overall bit rate : 1 097 kb/s
ID : 1
Format : ALAC
Codec ID : alac
Codec ID/Info : Apple Lossless Audio Codec
Duration : 3 min 28 s
Duration_LastFrame : -58 ms
Bit rate mode : Variable
Bit rate : 1 079 kb/s
Nominal bit rate : 1 411 kb/s
Channel(s) : 2 channels
Sampling rate : 44.1 kHz
Bit depth : 16 bits
Stream size : 26.8 MiB (98%)
Default : Yes
Alternate group : 1

WaveLab 8.5 was using Quicktime to open this file. But quicktime development has been given up by apple, and not 64 bit version is available. And WaveLab 9.5 is only 64 bit.
WaveLab 9.5 can open alac files, but not if there are embedded inside a mpeg-4 container, as your file.

Ah - that makes sense. Unfortunate, but I get it now. I’ll have to work with the files’ supplier to see what we can do on that end.

Thanks, PG.


I use foobar2000 as a quick way to convert when i receive those files.