Unable to play back on one of two computers

I’m afraid my Dorico 3 playback problem has nothing to do with NotePerformer. Playback works fine on the MacBookPro but on the MacPro the green playback bar stays put at the beginning of the music and won’t advance. Pressing stop removes the playback bar but if I try again, Dorico freezes and has to be force quit.

An additional problem: after working for a while on an existing file on the MacPro, Dorico suddenly slows to a crawl, e.g. a single action takes 15-20 seconds to complete. Although reloading the file doesn’t help, quitting and restarting Dorico returns behaviour to normal. Once again, I haven’t experienced this on the laptop.

P.S. I’ve installed the Dorico 3 patch, stopped the VST Audio Engine process in Activity Monitor, deleted the VST Audio Engine 3 folder in Preferences, and I’ve even changed the Preferences/Play/Default playback template to NotePerformer. So far, nothing has helped.

Have you performed the usual toggle between 44.1 and 48 kHz in the Audio device preference panel?

Vaughan, I agree with Marc that changing the settings in Edit > Device Setup will likely help with the playback problem on your Mac Pro. The sudden degradation in performance could be down to who knows what. Next time it happens, please do Help > Create Diagnostic Report and attach the resulting zip file here so we can take a look and see what might be wrong.

In Edit/Device Setup I don’t have the choice to toggle to 44.1 kHz. Only 48 kHz is available.

Perhaps you could, on the computer with no working playback, create a new project with a solo piano instrument, add a few notes, then save it, zip it up and attach it here for Ulf to look at. If you could also attach the zip file produced by doing Help > Create Diagnostic Report that would likewise be helpful.


I have the exact same problem here. I’ll try the suggested action.

Thanks Daniel! That did the trick!! The output in Edit/Device setup was somehow changed to internal output instead of built in line output. Now it works! The weird thing was that Dorico 2 played back. Noteperformer works also. Looking forward to delve in to the new amazing functions in Dorico 3!

My score (which uses EWQLSO/Play exclusively) won’t play back, either. If I load the project, wait for the samples to load, and then immediately attempt to play either the whole score or individual parts, Dorico 3 hangs and I have to kill the process.

I did manage to get everything playing once, but I have no idea how I did it, and so far, I’ve been unable to repeat the miracle. I tried Daniel’s suggestion of creating a score with nothing but a few piano notes in it, with the expectation that it wouldn’t play, but that works just fine.

My Device Setup values look OK.

So it is the project then. Would you mind sharing it with us? If you don’t want to post it here publicly, please send to ‘u dot stoermer at steinberg de’.

I’ve e-mailed it to you, thank you very much!

P.S. I’m running Windows 10 Pro, not MacOS.

Many thanks for the data. I had a first look but could not find anything obvious. Also, I don’t have the EastWest libraries so can’t load the project properly. However, if I choose the HALion Sonic playback template, it plays just fine.
How about on your end, if you choose the HALion Sonic template (for safety make a backup first), does it then play back? In that case, that would rule out device mapping issues.
And what are the exact symptoms? Does the green line move but no sound comes out, or does not even that move?
I don’t know EastWest, do the editor windows have an onscreen keyboard that you can play with the mouse (similarly to HALion Sonic)? What if you click there, does that produce any sound?

I haven’t installed the HALion sound samples, which I assume the playback template would require to function properly. (I will go ahead and install them if I can’t figure out how to get the score to play.)

When I invoke playback, absolutely nothing perceptible happens. The green playback line doesn’t even appear. Dorico just sits there, hung, interminably doing nothing.

Yes, the sounds work fine in the actual Play interface meant for the EastWest samples. The virtual piano keys produce the expected sounds.

Thanks for your time; I’ll keep hacking away. It plays just fine in Dorico 2, hopefully I can figure out the trick(s) to get it doing the same in the new release.

Okay, that at least proves that the audio engine is working and can produce sound.
Also the device mapping and routing is fine and nothing is muted in the mixer.
Only thing seems to be that playback just won’t start.
In the past we had a bug where Dorico and the audio engine would disagree on the current sample rate and therefore playback would not start.
We thought we fixed that, but could be not 100%.
The workaround was, go to Device Setup and change the sample rate to another value, wait a few seconds and then switch back.
That would bring the two in sync again and playback would work.
Does that maybe also get your playback going?

I can’t switch to another sample rate. 48K is the only option available to me.

OK, the workaround for me is to load the test piano score that I put together (again, as suggested by Daniel), invoke playback, then close that project and open my score. Playback works every time when I do this. (Both scores employ EastWest samples and the Play plug-in, exclusively.)

I would say that there’s something going on with the Play plug-in, but this never happened in Dorico 1 or 2. My installation of Play hasn’t changed since before I upgraded to Dorico 3, so it represents a constant. Something’s going on with Dorico, apparently.

Anyway, at least I have a reliable workaround that represents a minor inconvenience.

If you go to ‘Edit > Device Setup’ and then click ‘Device Control Panel’, is the option at the top of the window ticked?
It says something like ‘Allow ASIO hosts to take exclusive control’.

Okay, so you have at least a workaround. I wonder what happens if you set up a new project with Play, will it behave similarly?

No. I make sure that’s off.

Possibly. I’ve already set up a new project with that test piano staff using an EastWest sample, and that worked fine.

I may try it with my full orchestral score later, once I find time to go through the hassle of setting up the project from scratch, again.

And what if you switch that on? Restart Dorico and see if more sample rates are available.