Unable to Record Audio for Mastering

Hi, about a week ago, I discovered I was no longer able to record an audio track within Cubase to do my mixing/mastering. I can record/hear VSTs fine, and I can record/hear audio tracks I record with a microphone. But the audio track is not getting any signal from the sounds playing on my computer when I do so for purposes of mastering/mixing. Just a week ago, it was fine, so I’m sure its something small that I did which upset Cubase. Below I’m going to post pictures of my VST setup/routing/etc, since these seem to be the commonly asked for screenshots in the past.

This may be helpful also—things I have done recently which could be the culprit. I changed a driver setting (ASIO to DirectX, or maybe the other way around) in a sample-player/VST I was using; I tried changing it back but it had no effect. I also recently attached monitors to my audio interface for the first time, instead of using headphones—but I don’t think this would allow me to hear VSTs/etc, and then for some reason not record them.

Thanks
Device Setup 3.PNG
Device Setup 2.PNG
Device Setup.PNG

This forum limits the attachment uploads to 3, so here are some more relevant screenshots. Thanks again.
Vst Connections 2.PNG
VST COnnections 1.PNG
proj setup.PNG

If I understand the question properly!

To make a mixdown of your mix you should do an Export from the file menu.

Oh and the settings in System link are irrelevant, set them back to default and disable any duplicated midi inputs and outputs (emulated)