Unable to record audio through UR44 on LogicPro

Hello all!

In short, I’m able to record MIDI instrument tracks on Logic Pro but am unable to record audio tracks.

This is my setup:
I have a Yamaha workstation connnected to a Steinberg UR44 through the MIDI in/out port behind the UR44. A condenser microphone is connected to input 3 in front of the UR44.

I run LogicPro 10.3.2 on MacOS High Sierra.
I’ve installed the latest drivers from here:

I’ve also installed the “Tools for UR44 package:”

I’ve applied the latest firmware update too.

I’ve connected the workstation through the MIDI Studio .

What is working:
When I try to record MIDI instrumental tracks on Logic Pro, everything works fine.

Also, when I open the DSPMixFx tool for the UR44, I am able to see the rise and fall of audio levels from the microphone in input 3 on the mixer display.

What is not working:
I am unable to record audio on an audio track on LogicPro through a condenser microphone connected to the same audio interface.

How I attempt to record audio:
I open a new audio project in LogicPro and select “input 3” from the Steinberg UR44 input device already displayed. I am not able to obtain any signal in the audio track. Also, it does not show any live fluctuation in the mic input levels unlike in the DSPMixFx tool where the input is clearly seen.

I’ve made sure I’ve selected the UR44 through the LogicPro preferences.

I’ve tried choosing all the other inptus in the track, but still no response.

Is there any other setting that I’m missing?

Are there still known compatibility issues for the UR44 and LogicPro on MacOS High Sierra? Would it help if I downgraded to MacOS Sierra?

Thanks in advance…

  1. Did you enable monitoring on the Logic audio track itself in the Logic inspector area? Make sure the I is turned on for Input Monitoring and the R for Record as well

  2. Did you enable phantom power on that mic input on the UR? Condenser mics need POWER

Thanks for the reply.

  1. Yes, both the “I” and the “R” are turned on in the Logic Inspector area, as can be seen in the screenshot below:

2. Yes, phantom power (+48V) is enabled on the input to which the mic is connected on the UR44. (In fact, when the USB cable of the UR44 with the same recording setup is simply plugged into my windows PC, I’m able to record both instrument and audio tracks on Cubase Elements 9 without any hitch.)

  1. Check the INPUT you have selected as it appears to be set to Input 5

  2. Reset your UR44 in the Preferences/Audio and reselect your UR44 for the Output Device box

  3. Go to Preferences/Audio/General and make sure the Software Monitoring button is checked

Thanks for the reply.

  1. When input 3 didn’t work, I went through all the available inputs to see if there was a labeling problem. So that could be why it might show input 5 in the screenshot.

  2. Will try and update.

  3. Both “software monitoring” and “independent monitoring level for record-enabled channel strips” are checked in Preferences/Audio/General.

Can you post a PIC of Prefs/Audio Devices?

Also, Im trying to figure out why you have the YAMAHA USB driver loaded as well as the UR44 TOOLS?


  1. For giggles Id like you to TURN OFF input monitoring in Logic as well as the Independent monitoring pref

  2. Turn OFF the I on the track

  3. Open up the UR44 Console Software and move the fader up to 0 for that mic input and tell me if you get signal. the RECORD button stays on on the track

  4. Check the back of the UR44 and make sure its not ditched into CC mode

  5. Last thing is to try trashing logics pref file located at : Users/Library/Prefs/ com.apple.logic.pro.cs
    and also; com.apple.logic10.plist

  6. Finally, I would trash the Logic app. Go to the App Store , reinstall Logic (Last resort)

  7. Also, check to see if the UR44 is working with regular playback, youtube, iTunes etc.

Hope this helps

Thanks for taking the time to post a detailed reply.

Well, on the “Tools for UR44” page, it said to install the separate driver in case it was a more recent version compared to the one bundled into the Tools:

The TOOLS for UR come with a Yamaha Steinberg USB driver component included. However, a newer version of the driver for your USB audio interface might be available on this page. The driver component can be updated separately in this case.


I’ve already double-checked that the CC mode is off.

Will try the other points and get back to you.

Here’s a pic of Preferences>Audio>Devices:

  1. Turning off the input monitoring & independent monitoring preferences had no effect.

  2. Turning off the I on the track had no effect either.

Here’s a screenshot of the UR44 console. The fader is at 0dB, and the mic input is visible on the UR44 console but not in the Logic track:

Is LogicPro 10.3.2 qualified to run on MacOS High Sierra?

Im on 10.4.1 here BTW

In case Im missing a Logic setting here, you should also check www.logicprohelp.com and post this

Can you pull up Garage Band and see if you have the same issue as well??

Also , check the setting in the gear wheel in the UR Console, top right area


Also, https://helpcenter.steinberg.de/hc/en-us/articles/115001525990-Yamaha-Steinberg-USB-driver-installation-on-macOS-High-Sierra-10-13-

***Im assuming you have tried a diff mic and a diff mic cable as well, just covering all the basis

Thanks for the reply.

According to this apple page, Logic Pro X versions 10.3.1 and upwards are compatible with High Sierra:

Yes, I have the same issue with Garageband.

That driver is what I have installed. I looked at that page before the installation, but I never got a “System Extension Blocked” warning. The installation of the driver went smoothly.

Also, I’ve tried disabling the SIP through the boot menu.

I have only one condenser mic. Perhaps I could try it with a dynamic mic and with a different cable. But, as I said, the same mic setup works on Cubase Elements 9 on a Windows PC, so it’s probably not that.

  1. If GB is doing the same thing then it has something to do with the Core Audio Driver and or hardware I would think. Your signal is showing just fine int he UR software but its not passing it through the core audio driver into Logic.

  2. PRAM rest, Hold down Command + Option +P +R on boot and wait for the chime to ring 3 times then release and let it boot. See if that helps

  3. Can you get sound using the UR44 for the internal sounds, itunes, youtube etc? Go to AMS setup and set the UR to playback system output.

  4. Have you tried trashing the USB driver and re installing and aslo trying another USB port?

  5. Your mic and cable are fine

I think Im out of ideas here

Thanks for the reply.

  1. No, I’m not able to get playback using the UR44 for the internal sounds using Quicktime Player or iTunes. Currently all it’s able to do is to relay the MIDI from the Yamaha Workstation into Logic and playback the MIDI instrumental tracks from Logic Pro on the speakers of the Workstation & the speakers connected through the workstation.

  2. Removing & reinstalling the USB driver or trying another USB port have no effect.

Fiddling around with the settings behind the gearwheel on the UR44 dspMixFx didn’t solve the problem either, unfortunately.

Will try 2 (PRAM reset) and get back to you.

Just curious, if the problem is with the Core Audio drivers, what’s the possible situation in which it could be fixed? Do I have to wait for Apple updates and try them out, or can I download another version of the Core Audio Driver from some website? (Sorry if it’s a dumb question. I’m quite new to Mac & Logic)

Go to AMS setup and right click on the UR44 and select Use this device for sound output or something like that

It almost seems like the system is not seeing the driver for some reason

The drivers you downloaded are the correct drivers. Core Audio is just the Mac version of the ASIO

Tried setting the UR44 for use as sound output and input, and it still does not relay any audio in or out; just the MIDI.

Did you double check this: That driver is what I have installed. I looked at that page before the installation, but I never got a “System Extension Blocked” warning. The installation of the driver went smoothly.

Go to System Preferences/Security and Privacy and go to Privacy Tab/Accessibility and check there

ALSO: Go to the link below and CHECK THAT in the system. I had to check it here but didn’t get a warning either when I installed my MR816x driver


Outside of all those things, Im out of ideas here

Here is my AMS setup for my MR816X

Have you tried running the Tools installer and selecting the Uninstall for the USB driver then re install?

Sometimes this will clear things up