Unable to record midi

I am using a Yamaha s90xs keyboard and have just upgraded to Cubase 10 elements. Midi is plugged into my windows laptop via USB cable. Audio is routed from computer to Yamaha audio interface via USB. Successful in setting up the s90xs as a vst instrument. When I play notes on keyboard, I see the “bars” on the track, and on the lower right window of Cubase responding. Track,is armed ready to record. When I hit “record” and play my Yamaha keyboard, absolutely nothing happens…no midi notes are recorded. Have tried all configurations, using vst rack for the Yamaha, inserting just an instrument track, and inserting just a midi track. Same results. Thinking of reinstalling Cubase AGAIN. can you Help?

Check if MIDI filters are activated.

Under edit/preferences/midi filters, a window opens headed MIDI-MIDI FILTERS
note (record and thru
Program patch
After touch
SysEx…all same for Record and thru

Poly pressure

Below this list there are buttons 1-16 under heading CHANNELS. ALL are off
To the right of these buttons are CONTROLLER options. Only one is in the window “cc 123 (allnoteOff)

I have a screen shot, but unable to insert in message.
Is this what you are referring to?

There you have it.

You might probably want to uncheck these also.

Oh my but you are a genius. IT WORKED. I have been back and forth with Cubase and Yamaha for weeks and they did not suggest this fix. THANK YOU!

You ´re welcome. :smiley: