Unable to record Yamaha MX49 music to Cubase LE AI Elements

Hi folks,

I am new to music production but a piano hobbyist. I purchased Yamaha MX49 which comes with licensed copy of Cubase LE AI 6 and struggling to get it to integrate with Cubase :frowning: :cry: I have spent nights trying to figure it out and looking for some help.

I have followed the steps as per the forums and Yamaha/ Steinberg websites, and below are details:
a) My system details: Windows 10 (64-bit), Inter i-3, 2 GhZ, 8GB RAM, with NVIDIA GE force 930M graphics card :slight_smile:

b) Cubase with licensed elicenser -> version 6.0.5 Build 357 (64 bit) - build on Oct 2011 is working well! :mrgreen:

c) Installed latest Yamaha Steinberg driver V 1.9.9 (http://download.yamaha.com/search/detail/?site=usa.yamaha.com&language=en&category_id1=16244&category_id2=16381&product_id=1716498&asset_file_language=JA&asset_id=60554)

d) Yamaha driver is installed successfully, and appears in programs as ‘Yamaha Steinberg USB driver’ but doesn’t show any driver except for ASIO with no device (see screenshot)

e) Steps i follow are:
– Cubase was closed and Yamaha connected via MIDI to USB cable (See image 1), during installation of USB driver
– Changed Yamaha MX49 keyboard setting as described in the MX49 video (MIDI - ‘USB’ not 'MIDI, Quick Setup Type - ‘DAW Rec’ not ‘St Alone’ not ‘Arp Rec’) - (https://www.youtube.com/watch?v=Pm3evZm3FMY&list=PLpcwENKP6bGDpky7GcShr0hBWdNZyNdYK)
– Open Cubase and go to Device Manager, however, input ports don’t show Yamaha MX49 :cry:
– I followed video on youtube to try to get MIDI input but Yamaha input doesn’t show in the drop down not is the MIDI signal detected. (https://www.youtube.com/watch?v=hiIX2HaqEZ4) :confused:
– My MIDI USB cable is correctly connected with IN–>‘OUT’ and OUT–>‘IN’ . It signal from USB lits up but MIDI IN or OUT doesnt lit :confused:

I am wondering what I am doing wrong. Can someone please help? I am so eager to get started into some electronic production!! :ugeek:
Cubase 3.png
Device Manager.jpg
Driver2.jpg

Some suggestions…

Look at the keyboard user manual to find how to turn the “Local” function off. As you described, connect the keyboard to USB, turn it on, and set the “Local” function to “Off” BEFORE starting Cubase. Add an instrument track to Cubase and choose “All Midi Inputs”. Choose a VST instrument and choose a VST sound from that instrument set. Enable the track “Record Enable” and “Monitor” functions. You should be all set. Don’t forget to turn off the “Record Enable” and “Monitor” functions to hear your recording.

Regards :sunglasses: