Unable to rename audio file

I have a persisting problem with cubase 10 pro. I can’t rename my files, either properly or could not rename at all.

In the first screenshot, I could rename it, but the wavefile in the project window still shows the initial audio file name.

There is no problem when renaming midi tracks, only imported audio files.

In the second screenshot, I could not even rename it.

What’s the issue and how do I fix it?

Thank you!


Hi,

I don’t know, how did you try to rename the file.

But if you click to the track name, you don’t rename the file. You rename the track. If you double-click to the File field, you don’t rename the File neither. You just add a hint/annotation. So the new name appears in the brackets after the real file name.

If you want to get the same on the Audio Event, what you get on the track, keep the File field (in the Info line) untouched. Then double-click to change the track name. Don’t confirm by hitting just Enter. Hold down Ctrl+Enter. Then the Audio Event inherits the Track name.

I don’t understand what you mean by ctrl-enter. I tried doing that but it still says it cannot be renamed.

Previously I can just click on the audio file and at the top left corner where the file name appears, I can just rename it like that and the audio file name will change accordingly. And if I want an annotation like you mentioned, I use ctrl-enter.

But now, I can’t change the file name at all. Not even by using the Pool.

What’s in your pool, some files already exists with the name you want to rename another one?
I see in your specs, you have no computer :wink:
On Windows “Filename.wav” is the same as “FILENAME.wav”

This is in my pool right now.

Whenever I rename it, it’ll become Originalname(newname), which is not what I want.

I’m not renaming it to the same file name.

And what do you mean by no computer? Would that be the cause of this?

Hi,

Double-click the track name. Hold down Ctrl and press Enter. The Audio events gets the Track name.

I mean, no specs in your signature :wink: Sometimes it’s good know what the system is.

Have you tried to rename in the pool? What’s the content of the folder when you use the Explorer?

I tried to rename using Pool, but it’s still the same, says I can’t rename it. I have no idea what’s happening. Before, I could just rename it either using the pool, or the file info at the top left corner. Now I can’t and I can’t figure out why.

The contents in the folder is the same as the audio files that I imported into cubase. I also cleared the unused media and erased it, yet it’s still the same.

Has anyone encountered similar issues before? Is it a settings that I must have adjusted by mistake?

Hi,

Did you record the file or does it come from some 3rd party library? It might be, the library is packed (ZIPped) somehow, so you cannot change the name.

ok, my last idea, the file is readonly?

Nope, it’s not read only, and it’s also not packed.

I think I’ve figured out something: After renaming the file, the original file name still remains as shown in all the previous screenshots. However, it does change in the Pool. If I drag and drop that file from the pool into the working window, then it shows the new name (what I wanted). So is this a visual bug? But it can’t just be a visual bug, because I could still double click the original file name (even after renaming it), and rename it (only affects the annotation, original name still there, and the annotation appears whether I use enter or ctrl-enter).