Unable to use synthesizer as VST/MIDI controller in Cubase

This used to not be an issue.

Simply, when I load a VST I’m unable to play it with my PRO 2 as a MIDI controller. Neither with input set to All MIDI Inputs or the synth directly. Normally I’d figure it was an issue w/ my controller however it works without issue in Ableton Live, Renoise, and Reason.

Anything I might be missing in the Cubase settings/preferences?


What VST do you use? What is the “PRO 2” MIDI Controller, please?

It’s the Dave Smith Instruments PRO 2


Does the synth send MIDI data to the MIDI/USB out? How is the synth connected to the computer?

Try putting a MIDI Monitor Insert on the Track so you can see what data the Track is actually getting.

Total guess, but I’m thinking MIDI Channel mismatch.

Maybe a screenshot of the Track’s Inspector would be useful.

1 Like

Yea it’s the strangest thing.

I have an Arturia Keystep 37 & the PRO 2, both output midi signals as evidenced by MIDI-OX:


Next, when I load Cubase & add MIDI Monitor, only the Keystep outputs midi. Pro 2 doesn’t. You’ll have to take my word that I’m playing notes here:

Now the Keystep

If I open a VST in standalone mode, both keyboards output midi.

Do you have the Pro 2 set to output MIDI correctly? You could have it plugged in via USB but this setting set to “Off” or “MIDI” perhaps?


Page 87 of manual

…Or are you going through a MIDI interface and should have that selected in Cubase?

If the Pro2 is only connected via USB and not the MIDI Din out, make sure you’re not running any editor software or anything that uses that USB MIDI connection besides Cubase.


Double-check the settings in the Studio > Studio Setup > MIDI Ports Setup, please. You can also attach a screenshot of it.

Connected via USB, tried DIN as well through UFX Midi Port 1

Just a stab in the dark: Do you have the Pro2 ports in some way used as inputs for either Track Quick Controls or VST Quick Controls. I have a fleeting memory that this will lead to them not transmitting data on actual MIDI tracks any more.

Hmm, not that I know of

Maybe try reinstalling the Pro2’s MIDI Driver. Also what does the MIDI device look like in Device Manager?

I rolled back the drivers & reinstalled the latest to no avail. Appreciate the suggestions.

I had to add the PRO 2 as a MIDI controller under the MIDI Remote section.

Spoke too soon. This is really crazy.

So I know I have MIDI coming in based on the MIDI Activity but it’s not talking to the VST instruments…except when I’m on Chord Pads. Then I can play & record any VST as midi. But as soon as I move off the chord pads tab, nothing.


Isn’t the MIDI Port signed to the Chord Pad only then?

Not entirely sure what you mean. Can the MIDI port only be assigned to the Chord Pad? Where would I change this setting?

I’m also unable to route MIDI through to another instrument. For example an arp like Cthulhu. I have two tracks setup, one hosting the arp and the other another VST instrument. All of this worked in Cubase 11, I’m tempted to revert to see if it’s just me.

UPDATE: Everything works like a charm in 10.5 & 11. Not sure what’s up, the settings are the same. Tried reinstalling 12 - same.


You can try to copy Cubase 11 preferences folder and rename it to Cubase 12 v

1 Like