Unable to use the Tempo Editor

Hello all,
I was trying to use the Tempo Editor but without success. I don’t know if because I didn’t understand how to use it or not.

Here the initial situation.

Now I would like to move the starting point one quarter note earlier, lower the ending point (being a “molto” rit.), and making something to represent the fermata.

I’ve tried, in selection mode, to move the starting point a quarter node earlier, but all the line was move, not just the starting point. I’ve tried also pressing SHIFT, CMD, OPT. in any combination without a different result. Even worst was moving the end point to decrease the final tempo of the ritardando line.

So I’ve done it in the score fore the string point, and decreased the Final tempo % to a lower value obtaining:

To implement the fermata I would like to do what I’ve drawn in red in the previous image. So I clicked on the pen button, drawing some points below the end side of the ritardando line, again without success:

So, what I’m doing wrong?

Dorico is run on a MacBook Pro M1 in “Rosetta” mode to use NotePerformer 3. The Project I’m working on was create with Dorico 3.5, the updated to 4, 4.0.20, and now to 4.0.31.

The fermata realization does not have to be a gradual change but can be a (hidden) fixed new tempo in the final beat (or sub-beat) of the measure.
tempoTest.dorico (615.1 KB)


Thank you, @Derrek

1 Like

As you’ve found, Claudio, you can’t add additional points into the middle of an existing rit. or accel.: when you do so, the whole of the gradual change is overwritten.

Thank you Daniel.
What, instead, about the impossibility of moving the line points?

Sorry, what exactly do you mean? I find that I can move any individually selected point in the tempo editor with no problems.

Cia Claudio! I have this problem all the time and the solution for me has been to select the “molto rit…”, go to properties panel (below) and disable playback. Then just draw the ritardando however you wish on the tempo line! You’ll get a more human playback like this too!

Oh Dorico, oh Dorico…!
And then this tempo editor. I should be glad he’s even here! …
But - after I was able to get to the desired places to be edited with cunning and cunning - how do I get out of here?

Ah - finally - when scrolling by hand the sync breaks and the toggle is not visible. The only thing that helps is to select a different track in playback mode and turn on synchronization in write mode. Man - don’t you test at all anymore - now a serious question.

Oh Dorico, oh Dorico … !
Und dann nun noch dieser Tempo-Editor. Ich sollte mich freuen, dass er überhaupt da ist! …
Aber - nachdem ich mit List und Tücke an die gewünschten, zu editierenden Stellen gelangen konnte - Wie bitte komme ich hier wieder raus?

Ah - endlich - wenn man von Hand scrollt, wird die Synchronisation unterbrochen und der Schalter ist nicht sichtbar. Da hilft nur im Wiedergabemodus einen anderen Track auswählen und im schreibmodus die Synchronisation einschalten. Mensch - testet Ihr denn überhaupt nicht mehr - jetzt mal ernsthaft gefragt.

Here a short example explaining what I face with the Tempo Editor.

Screen Recording 2022-03-29 at 18.24.06.mov.zip (423.3 KB)

Moreover, Daniel, applying the @Derrek suggestion, here is how it appears in the Tempo Editor (to me is a bit confusing):

With the help of a drawn frame you can only select one of the right points - then you can move it.

Yes, this occurs because you end up with two points of different kinds (one point corresponding to the end of the rit., and one corresponding to the following immediate tempo change) selected: when you then perform an edit, the underlying editing code does the wrong thing. (The same was true in Dorico 3.5.)

This is certainly something that we will address as we continue to work on the remaining editors. Dorico 4.0.30 restores the tempo editor to the level of functionality that was present in Dorico 3.5, and we will move beyond that in future updates.