und wieder...Kratzer, Knackser........

Hallo in die Runde, ich weiß, dass dieses Thema nicht ganz neu ist. Leider habe ich nur ziemlich alte und auch nicht ganz zutreffende Threads darüber gefunden.

Ich habe mit Cubase 6 ziemliche Knackser- und Kratz-Probleme. Witzigerweise treten diese Phänomene nicht immer auf. Manchmal geht es stundenlang gut, plötzlich hat wieder irgendeine Spur bei jedem Notenerereignis einen Kratzer/Knackser. Das ist auch unabhängig davon, wie hoch der Buffersize eingestellt ist (aktuell 128 Samples). Auch ist mein derzeitiges Arrangement noch nicht überladen (7 Midi-Spuren)
Davor, mit Cubase 5 essential, ging eigentlich alles problemlos, allerdings habe ich mit dieser Version nicht lange gearbeitet, sondern ziemlich schnell das Upgrade gemacht. An meinem System (siehe Sig) kann es eigentlich nicht liegen. Ich habe schon das für mich ansich überdimensionierte Babyface angeschafft, der Rechner ist sauber und flott, und während der Sessions laufen auch keine anderen Programme.

Kann mir jemand auf die Sprünge helfen, in welche Richtung ich gehen muss, um dieses Problem in den Griff zu bekommen? Jeder Vorschlag ist willkommen.

-fiutare

Es gibt so viele Dinge die das verursachen können…
Erst einmal solltest du mit den Audioeinstellungen in Cubase ein wenig experimentieren.
Vielleicht ist es aber auch ein Problem mit einem Plugin.
Bei mir macht Native Instruments Reaktor 5 manchemal Probleme.
Problemlöung bei mir ist dann einmal die Audiopriorität in den VST Einstellungen von Normal auf Boost oder andersrum zu stellen.
Das einfache Umstellen schafft in dem Fall Abhilfe.

Probier mal Modus für Oprtimierte Audioleistung Haken zu setzen.
Ausserdem kannst du in den Energieoptionen von Windows mal das Speedstep abstellen vielleicht macht das bei dir Probleme.
Ich Arbeite mit C6 32 Bit auf Win 7 SP1 64 Bit vielleicht bringt dir das auch noch einmal Performancevorteile wenn die Plugs die du benutzt 32Bit sind.

CPU Knacksen:
was verwendest du für plugins und instrumente um Überlastung auszuschließen.
Auf die CPU Auslastungs-Anzeige kannst du dich nicht verlassen. Der i7 Verteilt die Prozesse, wenn du Multicore-Modus im Einstell-Dialog aktiviert hast über 4 Kerne bei mir macht er das ohne knackser bis ca. 40% Auslastung. Und da muss ich schon über 30 rverbs reinladen.

Festplatte-Cache Knacksen:
Wenn die Festplatte überlastet ist und du hauptsächlich Sampler als Instruments und Audio-Spuren benutzt kannst du mal gucken ob neben der CPU-Auslastung bei Knackser die Festplatten-Auslastung nach oben flippt. Dann brauchst du eine schnellere Platte oder noch besser ein Raid0(unsicher/regelmäßig backups machen) Raid10(sicher) System. [EDIT] Ergänzend sollten mehrere Festplatten eingesetzt werden um die Lese/Schreibgeschwindigkeit zu optimieren. Folgende Festplattenkonfiguration ist dringend zu empfehlen:
Windows -> Eigene Festplatte 7200U
Samples -> Eigene Festplatte 7200U
VST Librarys -> Eigene Festplatte 7200U
Projekte -> Eigene Festplatte 7200U

bei einer kleineren Konfiguration können Librarys und Samples zusammen auf einer Festplatte geführt werden.
Problematisch wird es mit einer Festplatte, da Windows und andere Apps neben dem laufenden Cubase Projekt AUCH einen eigenen lese/schreibe Datenumsatz haben. Wenn jetzt noch Samples durch Sampler von der selben Platte gelesen werden und 24-32bit Spuren wirds schnell eng. Folge: Aussetzer, Knackser, Dateilese und Schreibfehler. Daher viele Platten um die Lasten zu verteilen. Bei VST Librarys und Projekte ist ein Raid0 oder Raid10 sinnvoll.


Soundkarten-Sync Knacksen und Jitter:
Wenn das Knacksen immer heftiger wird und CPU als auch andere Hardware ausgeschlossen werden kann, ist ein Sync Problem bei der Audio-Karte manchmal Ursache… Ich kenne das RME Babyface nicht aber guck mal in den Treiber-Einstellungen ob es auf Master steht und intern clockt (wenn Einstellungsmöglichkeit vorhanden). Stecken noch andere Wandler oder Interfaces dran?

Plugins/Samples/Instrumente/Fades Knacksen:
Selten kann auch ein Knacksen am Ende eines Samples sein das sich anhört wie CPU Fehler oder in Audiospuren, die solche Knackser beinhalten.
Plugins… Manche Plugins fressen CPU ohne Ende und sind für den Mix mehr als Offline-Processing gedacht. z.B. PSP Master Compressor, Algorithmix EQs, usw… (Plugin-Manual lesen kann nie verkehrt sein).

Vielen Dank für die vielen Anregungen.

(fremde) VST-PlugIns habe ich derzeit noch nicht aktiviert (nur programmeigene, also Instrumente, Effekte, etc)), das Babyface steht auf internen Clock (als Master), den Realtek Soundchip habe ich deaktiviert. Die CPU-Auslastung ist in der Spitze auf 6%, meist bei 2-3%. Der i7 läuft auf 8 Kernen (hmm, evtl. virtuell, kenn mich da nicht so aus - es sind auf jeden Fall 8 Kerne zu sehen).

Ich habe jetzt eine neue Entdeckung gemacht. Heute Morgen lief erstmal alles gut, danach habe ich (bei geöffnetem Cubase) ein YouTube-Video angekuckt, zurück zu Cubase: rhythmisches Knacksen jede Viertelnote (mein derzeitiger Song läuft auf 60bpm, deshalb konnte ich mitzählen, LOL), obwohl ich Youtube wieder beendet habe. Ein Blick in die Fireface USB Settings (das heisst so, obwohl es das Babyface ist) zeigte neben der Einstellung für den Buffer Size, dass die Errors hochliefen. Diese beziehen sich nicht auf Pufferfehler, sondern auf das Auftreten von USB-Übertragungsfehler. Uff. Obwohl ich beide USB-Anschlüsse nutze (was angeblich garnicht nötig ist). Wenn ich den Buffer-Size hoch stelle (1024 Samples), verschwinden Errors und Knackser.

Hmpf. Dann hätte ich meine Sound Blaster X-Fi behalten können und mir die 500.- Öcken für das Babyface sparen können - grummel.

Ich werde das mal weiter testen. Interessant war schon, dass heute das Problem erst nach Abspielen des Videos wieder aufgetreten ist - und danach aber nicht wegging.

Hallo fiutare,
mit RME hast du schonmal nichts falsch gemacht. Die Geräte sind allgemein sehr gut von der Firma insbesondere die Wandler und Treiber-Einstellungsmöglichkeiten und DigiCheck.

Bei Asio-Treibern ist das so, wenn du Cubase öffnest werden die Audio- Aus und Eingänge deiner Karte mit Cubase durch Asio verbunden und synchronisiert. Du kannst keine zweite Software gleichzeitig über den gleichen Treiber Audio ausgeben lassen oder Windows Sounds wiedergeben lassen. Das zerhaut dir im Moment die Verbindungsstabilität in Cubase weil du die gleichen Ausgänge versuchst mit einer anderen Software anzusteuern…

Für optimalen Betrieb deaktiviert man sämtliche Windows Sounds.

Möchtest du beides haben kannst du versuchen deine On-Board karte wieder zu aktivieren. Diese dann als Standard-Ausgabe für sämtliche Windows Apps einstellen. ggf. ein Kabel aus dem OnBoardAudio-Ausgang in einen Input deines Asio interfaces, wenn du die Lautsprecher dort angeschlossen hast und keine andere Möglichkeit hast zu multen (wie z.B. bei fehlen eines seperaten Monitor-Steuerungs-Systems)… Dann hast du auch keine Probleme mehr wenn du zwischendurch mal per Windows was wiedergibst.

Alternativ, wenn die Onboardkarte generell Probleme bereitet -> “Deaktivieren” + Dann gibt es in Cubase Treiberdialog die Möglichkeiten die Asio-Verbindung von Cubase im Hintergrund zu deaktivieren damit notwendige Outputs bei Klick auf eine andere App, freigegeben werden können.

Bei Asio geht derzeit immer nur eine Applikation was durch die ganzen Aus/Eingänge, die mit der Software für diese Zeit “verschweisst” werden nur sinnvoll erscheint. Schiesst eine zweite Software dazwischen hast du Knacksen und sämtliche Sync Probleme, die sich durch buffereinstellungen nur verschieben… Du musst dann Cubase beenden und wieder starten damit die Verbindung neu und stabil hergestellt wird. Dann kannst du auch niedrigeren Buffer wieder nehmen, weil du vorbildlich interne Plugins verwendest :slight_smile:

Es gibt viele Rechner Optimierungs-Tipps und zu ASIO in der Steinberg Info Base. Empfehlenswert sich auch etwas Hintergrundwissen über den ASIO Treiber anzueignen. Das ist eine Cubaseunabhängige Ursache die durch nicht richtige Handhabung des Treibers entsteht.

Hast du in den Cubase ASIO Einstellungen beim Babyface alle Ausgänge und eingänge die du nicht benötigst ausgeschaltet?
Du solltest dann das Default Waveausgabedevice von Windows auf einen dieser Deaktivierten Ausgänge des Babyfaces leiten.

Das war die gute Nachricht :laughing:

Das leuchtet mir ein, allerdings glaube ich gelesen zu haben, dass gerade das Babyface sowas kann (mehrere Softwareanwendungen wiedergeben). Hmm.

Ja, das ist klar. Das hatte ich allerdings vorher schon so eingestellt. Ich kann das Gefiepse und Gefurze nicht ab. :wink:

Ok, das wär ne Lösung, auch wegen dem MediaPlayer und so. Ich kann mit dem OnboardSound auf einen anderen Aux-Eingang meiner Anlage gehen.

Oh ja, guter Hinweis. Sowas habe ich in den Einstellungen gelesen, glaube ich.

Naja, ob ich dauerhaft auf meinen Rez v2.0 verzichten möchte, den ich für Cubase 5 essential schon entdeckt habe… :laughing: - ich bin nur noch nicht so weit, dass ich die alle eingebunden und organisiert habe. Habe Cubase 6 jetzt erst ne Woche und wenig Zeit…

Jaja. Da sagst du etwas. Ich bin ein alter Mann, der nach 10 Jahren Pause wieder etwas Musik machen will. Davor war ich nur hardwaremässig unterwegs. Atari/Notator (am Schluss dann schon PC/Cubasis Audio) und TG77, Wavestation, Puschmilte, Behringer, Akai Sampler - das war meine Welt. Nujo. Ich kämpfe weiter, danke erstmal!!!

Yes


Hmm, heisst das, dass ich dann garnix mehr ausser Cubase machen kann? Hey, ich will weiter Rennen fahren!! :sunglasses:

Ich glaub, ich versuche erstmal die Variante mit dem Onboardsound.

Nein, Cubase und Windows könnten dann beide über das RME wiedergegeben werden auch wenn der ASIO Treiber nicht Multiclient kann.

Bei meiner RME 9632 HDSP ist das so.
Habe in Cubase als Ausgänge nur die Analog 1/2 und ADAT 1/2 die auf dem Stereo Out des Interfaces rausgehen.
Windows hat als Standarddevice ADAT 7/8 das geht bei mir noch auf den SPDIF der dann wieder in den SPDIF reingeht und in Cubase ankommt, damit ich auch was aus dem Browser/Windows in Cubase aufnehemn kann.

Aktuelle Treiber für das Babyface hast du dir hoffentlich runtergeladen?

Was ich bis jetzt gemacht habe:

  • Babyface geflasht (über fut_usb.exe - da gab’s tatsächlich eine neue Version)
  • Meine onboard-Karte aktiviert und als Standard-Ausgabegerät festgelegt
  • In Cubase Modus für optimierte Audioleistung angeschaltet
  • Festplatte defragmentiert (tief und gründlich)

Alles andere stimmt so, Babyface-Aus und Eingänge, die nicht benötigt werden, sind deaktiviert. Eigentlich ist nur der AN 1+2 Ausgang offen, da ich bisher nur mit MIDI und internen Instrumenten arbeite und noch garkeine Audiodateien aufgenommen habe.

So, dann habe ich mal munter den Buffer-Size auf 64 Samples gestellt und habe mich intensiv der Drumspur gewidmet, und ziemlich viel drin rumgefummelt. Danach habe ich zwei Durchgänge gemacht (Song dauert um die 4 Minuten) und beim zweiten Durchgang, gegen Ende und ohne Vorwarnung, ohne dass irgendetwas anderes dazwischenkam - plötzlich wieder Knackser, Kratzer. Und die Errors liefen wieder hoch.
Ich habe auf 1024 Samples gestellt - Ruhe war.


:imp:

64 Samples auf nem Win 7 System find ich grenzwertig.
Das hat bei mir Knackfrei nur die VSL 2020 unter XP geschafft.
256 Samples habe ich per Default bei meiner RME unter Win 7.
Wenn die CPU last mal fast am Anschlag ist schalte ich auch mal auf 512 oder 1024.
Wenn du das machst um die Latenz beim einspielen zu umgehen dekne bitte daran das jedes Dynamik Insert Plugin auch eine Latenz beim einspielen verursacht.
Dafür hat Steinberg extra diesen Kopf erfunden (s.U.) er schaltet alle Plugins ab die eine grössere Latenz beim einspielen verursachen.
Beim endgültigen Mixdown muss man diesen Knopf natürlich wieder deaktivieren.
verzEinschraenken.jpg

Moinsen!

Habe eure Diskussion über die Knackser-Lösungsansätze verfolgt und schreibe auch einfach mal ein paar meiner bescheidenen Ansichten in Forum. Ich arbeite seit 8 Jahren mit Cubase (vorher Logic) und bin eigentlich vollauf zufrieden mit den (mittlerweile professionellen) Möglichkeiten des Programms. Was Ressourcen angeht helfen in diesem Kontext meine UADs, die eine gehörige Portion Rechenleistung der benutzten Plugins übernehmen und die CPUs entlasten; ab 80 Spuren + Gruppen + Effektkanäle + VST-Instrumente kann dies entscheidend über eine konstant sichere Performance (oder eben Abstürze) sein.
Zurück zum Problem: Ich arbeite mit Firewire-Schnittstelle, was meiner Meinung nach Vorteile gegenüber USB hat: Sie gewährleisten eine höhere Datenübertragungsrate (wenn nominell auch bisweilen anders angegeben) und einen konstanten Datenfluss (ursprünglich konzipiert für Übertragungen von Digitalkameras und Video-Schnittrechnern). Will sagen: Trotz der außer Frage stehenden hohen Qualität der RME-Audiointerfaces kann ich nur zu Firewire in Sachen Audioproduktion raten.
Der zweite Tip (ungeschriebenes “Audiogesetz”): Auf dem Computer, mit welchem man Audioproduktionen macht, bleibt das Internet weg; sämtliche Netzwerk-Attribute, Anti-Popups, Firewalls, Antivirus-Programme deaktivieren (maximal einmal in der Woche bei vielem Datenaustausch die Platten auf Viren checken). All diese Komponenten bremsen das System. Klar, wenn eine reduzierte Cubase-Version genutzt wird und 5-6 Spuren im Projekt angewendet werden, macht das nichts - aber Cubase 6 ist ja für Größeres konzipiert.
In eigener Sache: Die Knackser-Problematik habe ich derzeit auch, allerdings nur ab und zu im Betrieb mit der 64-bit-Version; in der 32-bit Version läuft es bis dato unproblematisch. Wie schon vorher angesprochen, kann es auch an der Plugin-Kompatibilität der anderen Hersteller liegen (Bugs, Latenzen etc.). Ein tolles Beispiel hier ist Waves: Die Waves-Plugins laufen bis dato nur auf 32bit! Bei den Preisen eine absolute Unverschämtheit - wozu dann 64bit?
Ansonsten haben sich auch erfahrungsgemäß Probleme / Bugs nach dem Update neuer Cubase-Versionen in Luft aufgelöst - bleibt zu hoffen…
Grüße ins Forum, eskay.

:wink:

Internet:
einige Plugins setzen internet derzeit voraus. Ganz auf internet zu verzichten halte ich in 2011 nicht mehr für nötig und mehr als nervend wenn mal wieder eine ilok synch kurz durchgeführt werden muss oder sonstiges aktiviert.
bei mit läuft auch alles mit Internet einwandfrei. Früher bei den schnell überlasteten Rechnern hat das vielleicht Sinn gemacht…

Mal ne Zwischenfrage in diesem doch sehr interessanten Meinungsaustausch: Kann man “einfach so” auf 32bit umschalten, oder muss man dafür neu installieren schauder?

Du kannst im Grunde zwei Cubase-Versionen auf deinem Rechner problemlos laufen lassen: Die 64bit-Version muss dabei unter Programme / Program files installiert werden, die 32bit-Version unter Programme(x86) / Program Files (x86). Bei mir sind auch beide Versionen auf dem Rechner installiert, damit ich neue Komponenten auf dem 64bit-Cubase testen kann. Bis dato liefen meine UADs nicht fehlerfrei auf 64bit (erst seit Cubase 6); für umfangreichere Produktionen gehe ich deshalb auf Nummer sicher bei 32bit (s. Waves Kompatibilität etc.).
Also: Trotz Installations-Marathon kann ich es nur empfehlen!

Helau in 8bit, eskay

Also Cubase 32Bit gerade noch daneben installieren geht doch schnell…
Ausserdem hat man bei 32Bit Plugins mehr Puste.
Hier mal mein Test zur Performance mit 32BIT Plugins mit 5 Audiospuren in allen Inserts waren 32Bit Bootsy Plugins.
Also 8x5=40 insert Plugins (Epicverb, DensityMk2,NastyVCS,FerricTDS)
Hier die Auslastung bei gleichem Projekt mit Cubase 6:
VST32BitpluginsOnCubase32_64.jpg

Die Bitbridge schluckt natürlich Leistung und Bootsy Plug-ins sind zudem leider auch keine richtig programmierten Plug-ins das sind alles Synthmaker Plug-ins (dieses Baukastensystem) was konzeptionell natürlich sowieso nicht so performant ist. Haste das auch mal mit anderen Plug-ins getestet ob der Unterschied genauso groß ausfällt?

Ja, das mach ich dann mal. Die 64bit-Version hat sich gottseidank schon automatisch unter Programme installiert.