Undo thoughts, and an issue with audio track swapping

I made a slight mistake today on a track and hadn’t noticed so had to press undo about twenty times to get the track back to how it was. I was wondering if it could be possible to have a drop down menu that listed all the available undo’s so you could scroll down to find the undo you needed to go back to??

I’ve also come across this three times now in the past week (since I got cubasis) I’m not exactly sure why it’s done it each time, and will have to take note more closely next time. I’m finding audio clips are swapping tracks, for instance: the track labeled GUITAR has suddenly changed to having the MANDOLIN audio on its track, any one else found this?
I believe tonight it happened when I pressed the freeze by mistake, undo doesn’t revert the tracks back to their original status.

undo is best used to stop playback…

Erm, isn’t the STOP button best for stopping play back…clues in the name :wink:

Tried replicating the audio swapping bug, but can’t seem to get it to do it when I actually want it to (of course)

I think one of the things that causes the audio track swapping is copy/pasting several clips from different tracks.

For example, if you select and copy a section across 3 different tracks, if you don’t have the top track selected, it will screw up your tracks when pasting.

I can’t try it at the moment, but I had that issue a few times so now I’m careful when doing it.


Unfortunately we can’t change the behaviour of the undo function anytime soon because when tapping undo, Cubasis actually loads an old state (a backup) of the whole project. This can’t be done during playback.
Improving (or recoding) the undo system to only perform one action instead of loading an old version of the project file will take many months as we would need to recode everything from scratch. We have this on our feature request list, however due to other high priority tasks (automation, tempo track, time-stretch, etc.) the undo behaviour won’t be changed in near or mid-term.

so i waisted nearly €50 for an app that does not behave like any average app - that is to KEEP playing back while undoing the last edit??? that’s an epic failure ( especially when you consider where you placed the undo button )…
i wish i could ask for a refund!!!

Sorry to hear that the current undo behaviour is crucial to your experience with Cubasis. As with any other app, you can request a refund anytime on iTunes (AppStore). You can find many tutorials on Google on how to do that. Please note that after requesting a refund, iTunes will delete Cubasis from your device and you won’t be able to use Cubasis anymore (unless you purchase the app in the future again).

Thanks for replying crohde!
Yeah, I guessed it wouldn’t be an easy fix, and now I’ve been playing around with cubasis for a couple of weeks I don’t find it as much of an issue after learning from my mistakes.
Really enjoying cubasis, finding a few issues that ARE a bit frustrating, I’ll see if I can remember them all :slight_smile:

The two marker points are very frustrating. I’ve seen other people mention the same thing: a simple lock to keep them from being moved would be fantastic, I’m forever moving them by accident.

Why did you not allow two audio clips to be glued together? Would love to be able to glue all my little clips together to make ONE clip…

Would be nice to change the colour of individual clips in a single track, rather than just being able to change the colour of the track as a whole.

Having to select track one if you want to copy and paste multiple track clips seems a bit odd (as mentioned by the person that kindly first replied to my original post) easily worked around, but a little odd?

What would be fantastic, but I’m guessing would be way too much work is a small ‘favourites window’ where you could choose a few basic controls to place in the window where ever you want on screen, meaning the main tool bar window could be kept closed, and perhaps avoid constantly hitting buttons by mistake?

Like I said, am having great fun with this app, my ideas above are in no way a criticism of your hard work, but a few personnel thoughts never hurt

Can’t wait for the next update!!


It stops playback, I get that. It’s not the end of the world. Deleting tracks and moving data around is!

On multiple occasions undo has removed a track then shifted everything down a track. That is in no way a small thing and demands immediate attention. I can’t even select everything and shift them back into place because it converted some of the tracks from MIDI to audio to accommodate the shifted material.

For you guys to say you’ll get to it when you get to it is completely unprofessional. This is a huge bug and not a feature request. I understand people want audio stretching but that needs to wait. This undo button is destructive. please give it the urgent attention it deserves.

I’ve had glitches like these too, unfortunately I couldn’t reproduce them.

It kind of reminded me of the weirdness that happens when you past events from multiple tracks without selecting the top track first, where it just messes up all the tracks. Definitely needs to be improved.

Eek, I just had this happen for the first time as well… Undo’d a few editing steps, then suddenly, a MIDI track with a Micrologue instance was completely gone, its parts instead played by the track below it… I also found no way to “undo the undo”…

This is for sure an inspiration killer :wink:

Something’s definitely messed up in the “undo” behaviour.
If all it was doing was reading an older slate of the song, then these weird issues wouldn’t occur, so there’s gotta be something wrong in the way Cubasis is reading those files…

Yep I thought that too, the “re-read old song” way should actually be fool-proof. A rather complex app I was involved with development-wise (Blender, 3D software) does exactly the same thing, and it works without a glitch there. Although it has a seperate undo stack for certain modes, which only saves the relevant data for those. Could be applied to Cubasis and the Piano roll editor as well.

But I’m sure the devs know and are working on it already :slight_smile:

I think the first step is to get the devs to acknowledge that this is a bug and not a feature request, and possibly not even related to loading a previous state, and if it is, acknowledging that it isn’t working correctly. I don’t think that will happen until someone can post reproducible steps. I have tried to reproduce it several times and nothing, although it has happened to me at least 3 times randomly.