Unequal line spacing in parts

Hello Dorico community, Dorico automatically inserts a greater line spacing when there are Rehearsal marks. The same too if there are any kind of tempo markings above the stave. See this pic, where extra space is produced for the rehearsal marks and for the Rit…molto.


Is there any way to override this? I don’t think uneven line spacing looks nice at all. I like my staves in a single instrument part to be the same distance apart.
Thanks.

This is a frequently discussed request on the forum. Yes, rehearsal mark spacing needs to be improved!

Thanks Dan.

You might find changing the vertical justification settings for parts like this (where each system only contains a single staff) produces more even staff spacing.

In Setup > Layout Options > Vertical Spacing > Vertical Justification, try making the value for Justify distance only between systems when frame is at least [n]% full the same as or smaller than Justify distance between staves and systems when frame is at least [n]% full.

(There are some recently-updated tips about staff spacing settings here)

The most important of the tips that Lillie has added to the documentation is that you should set the distances on the Vertical Spacing page of Layout Options to the smallest values you would be willing to accept, and then rely on vertical justification to move things further apart. The reason for this is that Dorico essentially adds up the height of the staff plus whatever gap or gaps applies below that staff when determining the height of the unit that it then spreads out with vertical justification. You can imagine it like drawing another staff line however many spaces you have specified for the relevant gap value, below the staff, and unless the frame ends up over 100% full, Dorico won’t allow any part of the system above or below to cross that line. The larger that value, the greater the chance that things that stick out above the staff, like rehearsal marks, will run into that imaginary staff line, thus preventing Dorico from bringing those staves any closer together.

So my advice for part layouts with a single staff would be to set the distance between systems to a smaller value, e.g. perhaps as small as 4 spaces, which should allow Dorico lots of leeway when performing vertical justification, and you should then find that rehearsal marks have much less impact on the final staff spacing.

It’s also worth saying that we have recently made some improvements to the vertical justification algorithm that will make a particular difference when pages are not especially full, which is the case in the example posted in this thread, and these improvements will be in the next major version. The next major version will also include a read-out at the bottom of each frame to tell you how full it is vertically when the staff spacing tool is enabled in Engrave mode.

Cool! I’m looking forward to that. :slight_smile:

I’m still trying to get to the bottom of this, but I’m finding the opposite is sometimes true. Here’s an example. In the flute part, if I set the inter-system gap to 10, I get a pretty decent spacing, but if I set it to 5, the rehearsal marks suddenly demand more space. Confusing.

I’m investigating because rehearsal marks are often the single thing that requires manual staff spacing for me. It’s hardly much of a trial, but it still feels unnecessary.

Hi Dan, that’s because your Justify distance only between systems when frame is at least [n]% full value is larger than the Justify distance between staves and systems when frame is at least [n]% full value (which I suggested to make the same in my previous post in this thread).

Because this part is somewhere between those two values (of 80% and 60% full respectively), Dorico is automatically vertically justifying the staves but not the systems; and because Dorico sees there’s some extra space available, it’s allocating proportionally more space for systems with rehearsal marks. If you change Justify distance only between systems when frame is at least [n]% full to 60% and then make the inter-system gap 5, the systems are evenly spaced. Making those two values the same for part layouts that contain a single staff is your best bet for producing consistently-spaced parts.

Bingo. Thanks Lillie!

Sorry guys, but making proper layouts with rehearsal marks in Dorico drives me completely crazy.
Dealing and playing with the spacing options in engraving options for nearly 1,5 hours now and the score still looks bad. I have to move every rehearsal mark and nearly every stave manually…that’s bad…too much time gets lost here…

More than an hour? That sounds a little too long. Two things:

You shouldn’t need to move all rehearsal marks. In Engraving Options, you can set them closer to the staff (or to protruding items).

Second, hopefully you’re not using the mouse to move staves. Instead, use the keyboard. In Staff Spacing, use these commands:

  • arrows move between handles
  • tab toggles between system handles and staff handles
  • Alt-arrow move staff small amount
  • Ctrl-Alt-arrow moves staff large amount

I’m looking forward to improved rehearsal mark spacing too, but using the keyboard really does make it pretty quick.

thanx so much Dan…nearly jumped out of the window here. I’ll take your advice(s) for my next try.
Topic is bookmarked :wink:

I find it’s sometimes faster to set Engraving Options/Text/“Position of text relative to other items” to Use Default Position instead of Avoid Collisions. Obviously you will then have lots of collisions with system text and rehearsal marks, but these are easily and quickly fixed with Ctrl-Alt-arrow, and you won’t have the crazy staff spacing issues that Avoid Collisions often causes with rehearsal marks.

Can you post this project (or a version with it cut-down with just an example part where this is happening)? I wonder if adjusting your per-layout vertical spacing values would do a decent chunk of the legwork, I’d be happy to take a look - if you’d rather not post to the forum you can email me: l dot harris at steinberg dot de

A lot of very good advices which I didn’t take into consideration.
@ Lillie: after having read this whole topic, I played a long time with per-layout vertical spacing - that’s why it took so long.
It was like gambling - you raise the one number and strange things happen, you raise another one, other strange things happen. I like maths but for me understanding all the relationships between the numbers and their effect on the vertical sapcing is quite difficult and more like playing roulette. Sorry :smiley:
I’ve sent you the project by eMail.
Thanx for your help.

Uhhhh…strange things are happening here:
Before:
Bildschirmfoto 2019-07-14 um 11.46.48.png
Then I go on: make into system and this comes out:

That looks like it’s because the system is now overfull due to the horizontal space required for the lyrics and the amount being forced into the system. Activate Note Spacing in Engrave mode, and you’ll be able to see what percentage full it is: if the indicator on the right of the system is red, then Dorico considers it overfull.

I don’t seem to have received your email with the project, were you able to ‘translate’ my description into a functioning email address? (We type out the email address in order to avoid it being picked up and spammed)

uuuppsss… I wrote ‘steinDberg’…hahaha…on it’s way again.
Thanx for all your help.
Mail is sent.
And: my next score i made without rehearsals marks and it’s much easier for the layout…

Yes… try 3 bars per system. There’s way too much with 4.5 measures.