Uneven note spacing

While writing down some exercise patterns, I’ve noticed that the layout of some sixteen notes is note perfect.
To make sure that it’s not something specific to that project, I made a quick test project entering simple tetrachords with all default settings except setting a fixed number of bars per system - 6 and deliberately leaving out any extra items such as articulation, dynamics, etc.
And yet, the result was the same.
Am I missing something, or is it a minor kink in the layout algorithm?
I’m on iMac 27’’, i7, 8GB
Igor Borodin

It’s the ledger lines that are causing the unevenness in the spacing: you’re forcing more bars per system than Dorico thinks should fit, so it’s squeezing those 16ths together because that’s the only place it can borrow the space from. You might try either forcing fewer bars onto the system, reducing the staff size, widening the system (e.g. by changing the page size or reducing the page margins), or reducing the note spacing values in Layout Options, or some combination of these options.

Thank you, Daniel for instant clarification.
Which of the options would yield the most legible/natural look?

It really depends on what you’re hoping to achieve. If you don’t need to force the number of bars per system, that’s the first thing I’d disable. Let Dorico space the music without forcing too much on the system: there’s a reason why Dorico doesn’t put six bars on the system by itself, and that reason is that, with that staff size, those note spacing values, and that available width, they just don’t fit.

The exercises are meant for displaying in an application for student practicing.
Due to some specifics of the practice workflow, I need to keep the number of bars.
So, I’ll try reducing the margins or increasing the page width.
And another question: for some technical reasons, I can’t use pdf for displaying the music (Windows ‘WebView’ class does not support PDF). So, I have to present it as PNG.
Are there recommended (empirically found) optimal values for staff size when the music is presented as png?

No, I don’t believe so. But use a high DPI value when exporting and you should be fine.

Thank you, Daniel.

The example provided seems perfectly legible–except for the uneven semiquaver spacing. If this were to be made more beautiful the result would surely pass muster in any orchestral part.

One of the characterisics of music printing software is that it wants to fit less bars on a line than the method of traditional engraving achieved. I find this particularly actute in setting Beethoven 3/4 Scherzos. The knock on effects of this are that it becomes difficult to find good places to turn the pages and that the movement takes up more pages.

Would it not be possible to define an alternative, higher note density? This could be called “tight-density” or something similar to denote that its use is not standard. I for one would find this very useful, and it would help in the present case. With Sibelius it is always necessary to defeat the spacing algorithm by hand in such Scherzi by using the “make into stave/page” commands.

A command to change the spacing rule by a percentage might do the trick.


Daniel’s advice to adjust the available width by reducing the margins did restore evenness in layout in my case.
At the same time, I think that David’s proposal of ‘tight-density’ - an option of going beyond default threshold of density and thus distributing the shortage of horizontal space between all items in the system more evenly - would be quite helpful in some cases.

The first thing I’ve always done in similar cases is to reduce the note spacing in Layout Options/Note Spacing (or via Engrave/Note Spacin change) THEN maybe consider a slight change in Engraving Options/Notes/Ledger Lines… protrusion

Thank you for the suggestion.
I’ll definitely give it a try.

Yes, you can use the Note Spacing Change feature to specify a tighter default spacing for a passage of music very easily in Dorico. Dorico is the only scoring software that can match the tight spacing of hand engraved music, but there are still limits to what it can do automatically, particularly when you start forcing more bars per system than the ideal rhythmic space defined on the Note Spacing page of Layout Options allows. Reducing the spacing values there (or using a Note Spacing Change) will provide more even spacing under duress, but obviously at the expense of reducing the difference in rhythmic space produced for notes of different durations.

Thank you for further guidance, Daniel.
I did try playing with Note Spacing.
And indeed it’s very convenient.
Alas, there is a downside of messing with default spacing (unless I miss something). Reducing Note Spacing value distorts the original look of Dorico notation - very nice, proportional, easy to read. The stems become disproportionally long thus making it look even more squeezed/cluttered.
So, for my purposes - presenting the notation in the web application - the optimal solution is to increase the available width; even at the expense of notation’s final appearance looking a little bit smaller.