Unexpected reduction results

Hi.

Please look at the attached gif:

(I choose “Reduction” from the menu that you can’t see because of the narrow view port.)

I have 2 players, Alto Saxophone 1 and Alto Saxophone 2, and wanted to reduce them to one single “Alto Saxophone 1+2” line for the conductor score.

The unexpected result:

  • It has the voices switched: All the higher notes from AS1 are in the “stem down voice”, and all the lower notes are in the “stem up voice”.
    The source material is all just one voice per player, there have never been additional voices.
  • Although in measure one all the note values are the same, the content does not get reduced to one voice.

Completely off topic:

How do you do those animated GIFs?

I tried your exact example, and the result I get is closer to what you would expect.
I think you may have accidentally switched Alto 1 to a down-stem voice. Since it’s the only voice in that staff, it looks the same, but when you combine it with another voice, the result is messy. Change it from Right-click > Voice > Default stem up, and let us know if you still can’t reduce as expected.

I think Dorico only collapses voices that are rhythmical across all bars, so if you want a single voice in one bar, and two voices in another, you’ll have to do them separately.

Hi, Anders.
Thanks for this idea - I woldn’t have thought of this because like I said, I have never messed around with voices because I’ve never needed more than one voice per staff.
How can I find out what type of voice my notes are currently in?
When I select a note of Alto 1 and choose from the context menu “Stimmen” (German for “voices”) > “Stimme ändern” (“Change voice”), the first option is “Stimme 1 Hälse aufwärts” (Voice 1, stems up). Now I don’t know if that means that the note is currently in a down stem voice… If that really is the case then I really have a problem, because the same menu item shows for all my notes in all players across the whole project, and I’m pretty sure I’ve never changed all voices to down stem voices…

Why not turn on Voice Colours? If all voices really are the same they’ll all show as the same colour (probably lgbt blue).

Great idea :smiley:

It shows both Altos as being the same (default) voice.

In the meantime I’ve found something out that might be interesting for the Dorico team:
If I paste the reduction into a staff that has had only one voice (or was ever completely empty), the reduction is perfect.

In my case the target staff has had 2 voices: The first one had been used for the Alto 1, and a second one that had been created when I did “Paste into new voice > new downstem voice” with the Alto 2 notes. As I mentioned in the top post, this staff was used to hold a combination of Alto 1 + Alto 2.

What I did before I went to test the reduction feature: I selected everything that had already been there and pressed .
It seems that somehow this second (downstem) voice was kept active, so when Dorico pasted the reduction into this staff, the notes from Alto 1 were put into this still active downstem voice, and the notes from Alto 2 were put into a new upstem voice.

I’m a bit confused, because after my “delete everything” action I did not even think of the possibility of voices being active or not.
I’m not sure that the current behaviour is expected behaviour in any way. Either Dorico should reset voices when I “delete everything”, or Dorico should start with voice 0 when doing the reduction. Or at least give me some kind of warning. I don’t know. It just feels wrong in a way…

There was certainly a thing whereby if you delete the contents of a voice, the voice doesn’t actually get removed from the file until you shut (and presumably reopen) the project.

V2 is the first time the Reduce function has become available, so I guess it’s the first time that this voice-deletion-not-deleted thing may be causing problems. I don’t have the Version History to hand so I can’t confirm if this behaviour has been fixed or not.

FWIW I work with voice colours on all the time - I can’t see any reason not to, really!

Well, since I don’t need voices at all (besides those “reduction” staves), I would end up with lots of unneccesarily colored notes :smiley:

One thing that bothers me is that there is no way for me to know what voice the copied notes will be reduced into. The empyt bar shows a blue (default?) whole break and when I put in regular notes they get colored blue like everything else. But when I paste the reduction into this very place, the voices get scrambled.
(When I paste the same two lines into the bass clarinet staff that is directle above Alto 1, everything is ok…)