Unrecognized audio interface

Hi,

I’ve recently updated my cubase to pro 10 (from artist 9). Since I’ve updated it cubase stopped recognizing my audio interface (Roland Studio Capture).
The thing is on cubase artist 9 everything worked fine just a moment ago. I already know the “Studio Setup” menu in which I’ve looked for all the available ASIO drivers, I can see the roland there. However, if I choose “STUDIO-CAPTURE” an error is returned: “Can not found a device. Please connect the device.”

I tried everything, restarting the computer, the device, cubase, all of the above together, reconnecting cables, still nothing.
I’m completely sure that it’s a cubase problem because everything on my computer works well with the audio interface including the old cubase that is still installed.

Specs:
Windows 10
Intel i5 4690
RAM 16GB
NVidia 970
Roland Studio Capture
AKAI MPK mini (probably not relevant but does add an ASIO driver so maybe worth mentioning).

I tried all the usual troubleshoot options, and I couldn’t even find the option to submit a ticket because the steinberg website is telling me to contact my local distributor.

If you already tried completely reinstalling CB then I would try this…

  • If applicable, in Win 10, delete the mixer and other software associated with your AI.
  • Go into the Win 10 device manager and delete your AI hardware device then reinstall it by reconnecting it.
  • Reinstall the device software and driver. Make sure they are the latest versions

Good luck.

Regards. :sunglasses:

Edited to correct spelling…

I found something similar, through control panel -> uninstall programs, I’ve uninstalled all the relevant drivers.
Then I did the same, reconnected the device to reinstall the drivers and it worked.
It seems that the cubase installation messed up the driver a little bit but now it works.
Thanks :slight_smile: