Unusable after Dorico prevents shutdown

Occasionally, I’ll rush to shut down my Windows PC before closing Dorico properly. Dorico rightly intervenes and interrupts the shutdown, asking if I would like to save my changes before exiting.

At this point, I’d like to save my changes and continue with the shutdown.

Unfortunately Dorico has already moved to an unusable state, where saving changes is no longer possible. Trying to save a document hangs Dorico.

It looks like Windows closes the audio engine prematurely, preventing Dorico from operating as expected.

to help you, can you indicate :
version of Dorico, of Windows and e-licenser ?

Thanks – I’m running Dorico, Windows 10, and eLicenser 6.11.10.

Steps to reproduce:

  1. Open existing Dorico project
  2. Make changes
  3. Shut down Windows
  4. Abort shutdown on warning re: Dorico still running
  5. Attempt to save changes

First I would update e-licenser and Dorico.

I was unable to reproduce the problem on a current Windows 10 PC with the latest Dorico and e-licenser Updates installed.

Thanks both. I just updated to the latest version of Dorico and the eLicenser: same result unfortunately.

I imagine there’s an issue with your audio drivers that could be causing the problem, Chris. Can you try updating the drivers for your audio device?

Thanks Daniel. I’ve just updated my audio drivers, and I’m getting the same result. I’m using a fairly standard setup: Focusrite Scarlett 2i2, and up-to-date Windows 10.

Here are some slightly easier steps to reproduce:

  1. Launch Dorico
  2. Select ‘New Empty Project’
  3. Use the Start Menu to restart
  4. Select ‘Cancel’ on the OS warning re: Dorico still running
  5. Select ‘Save’ on the Dorico dialog box

Dorico hangs for me every time. Are you able to reproduce on your end? If not, would it be helpful to supply logs or a video?

I can reproduce this on my PC. And I must admit, I can even reproduce the earlier problem now. I hadn’t followed the steps all the way previously.

I’ll discuss this with the team and we’ll see what we might be able to do about this in a future version. I’m sorry for the inconvenience caused in the meantime.